KNetwork Manager disabled

So, I did a fresh install of OpenSuSE 11.3 KDE 64-bit on my new laptop. Worked like a charm. But I brought it with me to work without connecting it to a wi-fi and now the network manager doesn’t want to start when I’m back in range of my home connection.

Also, whenever I try to launch KNetworkManager, it won’t load up a window and I still can’t connect. This is even disabling the Ethernet port also.

I came to SuSE from Ubuntu, so I’m not a complete Linux newbie, but I’ve primarily used Gnome from all my other usages.

Please Help!

And a bump …

I’m solving this with a re-install. It’s probably not the most practical way out there, but I want to re-partition my HD anyways.

Based only on my personal experience,
Knetworkmanager only seems to work best when it has been continuously connecting to a network. When traveling between networks my machine is put to “sleep” – not shutdown. This means that oftentimes I’m not actively connected to a network, and then Knetworkmanager seems to go “dead” – It can’t be re-invoked and so far I haven’t found a way to restart it reliably… have tried invoking from the CLI, KDE Run…, KDE Menu, /etc/init.d/network restart, they all only work if recently connected to a network but won’t work if Knetworkmanager has gone inactive/died.

My solution has been to do a complete shutdown/restart whenever I wish to connect to a network.


I have the same problem with my laptop - after switching on from the suspend mode the wireless is off and knetworkmanager just displayes “Networking disabled” after clicking the icon in the panel.

My solution is to install cnetworkmanager package and run ‘cnetworkmanager -w 1’ command from a terminal after resuming from suspend. Also I have to manually activate the wireless HW - in my case (Acer laptop) by pressing Fn + F3 (that of cause depends on your laptop).