knetwork cannot start...

opensuse 11.2
kde 4.4.2

I having problem after doing update today using zypper up

I get this error when I try start knetwork

“knetwork manager cannot start due to misconfigured. system dbus policy does not allow it to provide user settings”

how do i fix this? :’(

I guess you are using Factory? Am I correct?

yes. i using factory

There was a bug in a update yesterday I think.

To roll back if you cannot get any connection at all even with wired eth0, and using ifup instead of network manager. You can roll back by disabling all repo’s and leaving the cd or dvd install media available and roll back network manager to the version there.

If though, you switch to ifup you may be OK anyway. Especially with eth0

thanks. you’re right . I change the network setting to ifup and my eth0 start working

Do you know what the bug was, perhaps? I’m having the same problem but I cannot find a recent bug entry specific to this issue.



Create a file called /etc/dbus-1/system.d/NetworkManager-kde4.conf

with the content

<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
        <policy user="root">
                <allow own="org.freedesktop.NetworkManagerUserSettings"/>

                <allow send_destination="org.freedesktop.NetworkManagerUserSettings"/>
        <policy at_console="true">                                                            
                <allow own="org.freedesktop.NetworkManagerUserSettings"/>                     
                <allow send_destination="org.freedesktop.NetworkManagerUserSettings"/>        
                <!-- Only root can get secrets -->                                            
                <deny send_destination="org.freedesktop.NetworkManagerUserSettings"           
        <policy context="default">                                                            
                <deny send_destination="org.freedesktop.NetworkManagerUserSettings"/>         
                <allow send_destination="org.freedesktop.NetworkManagerUserSettings"          
        <limit name="max_replies_per_connection">512</limit>                                  

That file was left out of the rpms.


Thanks this fixed my problem with that
Though i have seen it to happen in some previous updates 2-3 times and
was fixed every time with a reboot, but now had stayed there permanent.

So ^^ this fixes the problem :slight_smile:

Will has pushed the patch that fixes this problem to

However KKFD publishing is disabled atm in preparation for KDE SC 4.4.3
release, so it may have to wait for that.

In the meantime use the dbus-conf file specified above.

Thank you so much for publishing this file. Worked just as advertised.

Today’s update with kdesktop repository
made amarok to loose sound.
Also i saw again the D-BUS message but fixed after reboot.
Why is that happening?

Start a new thread. This one is about the networkmanager, your reply is about amarok. This could mean you will not get attention for your problem.

Ok the tread is this
cannot play music after upgrading to KDE 4.4.3 - openSUSE Forums

but what about the D-BUS message that is always shown every upgrade and system
needs to be restarted?