KMozillaHelper asks me for file associations

Hi. I use Archlinux, and was little annoyed by the lack of integration between Firefox and KDE. But thankfully You openSUSE guys made some work on it, so I thought I’d give it a shot :wink:

Big advantage of Archlinux is that there is something like Arch User Repository, which contains scripts which are seen as meta-packages. As an example, here:

AUR (en) - firefox-kde-opensuse

when you click on the PKGBUILD, you see what’s being executed when I try to install this package:

This is just in case if you wondered how it works in my Arch.

So, I described a lot, and here comes my problem. And since movie is more worth than 1000 words, here it goes:

Video - TinyPic - bezpłatny hosting obrazów, udostępnianie zdjęć i hosting filmów wideo

So, the problem is that even though .exe files are supposed to be ran with Wine, I get a prompt from KMozillaHelper asking which program to use. I tried writing wine, selecting “Bind this program to this filetype” etc. and still the same window appears. It happens quite often, actually, not only with .exe files. What’s funny, is that when I click the radio button to “Save” and then double-click the file in the Downloads window, it opens with the associated program with ease.

Go to System settings>Advanced>File associations.

exe is recognised but no application is listed. Add wine and hopefully all should be well.

Still no go :frowning:

It’s hard to believe - even though Wine was set right, etc., etc. this KMozillaHelper window still pops up.

It also happens with some .rtf files (Open with OpenOffice Writer), and after downloading, I need to type “soffice” in KMozillaHelper every time. What’s absolutely SHOCKING about this .rtf issue, is that it only happens with one .rtf file which I have as an attachment - when I tried googling “oferta filetype:rtf” and then entered the 3rd link:

Firefox asked me if I wanted to open in Writer or save, I chose Writer, clicked OK, and everything was smooth as butter. So it also might be dependant on the situation, not only filetype. But how could this be possible, I have no idea.

When You visit and try to open in Wine one of the WinRAR installers from Firefox, does it work?

PS.: Could it be because file on my e-mail is .RTF, not .rtf? But in the file associations menu in KDE, I also added *.RTF mask, so it shouldn’t be a problem. And that doesn’t explain why KMozHelper pops up w/ *.exe files…

PPS.: Some other files work fine - i’ve got dolphin set to open .zip files here:

and works great.


See here:

The Chakra Project - Forums / Firefox with KDE integration (OpenSuSe build)

It started to work the moment I removed kmozillahelper (-Rd on that post means “remove without dependency checks”)/

After recompiling xulrunner with the patch and with kmozillahelper ON, the error still was there.
So in the end, I don’t know what was causing this - was it xulrunner AND kmozillahelper, or only kmozillahelper. Will investigate.

Right now, it is important to track the bug in kmozillahelper.


The Chakra Project - Forums / Firefox with KDE integration (OpenSuSe build)

See last post. The one in kdemod repo (which is making the problem) is still 0.6-1 version, but the fixed one from AUR (AUR (en) - kmozillahelper) is 0.6-2 and fixed.