Kmix won't load, Where to start? Troubleshooting microphone

Am not sure where to start troubleshooting this… Kmix isn’t loading.

Loading from the KDE menu, I get a busy arrow cursor indefinitely.
Loading from a Terminal, the command is accepted but no error displays.

If Kmix is a lost cause, is there an alternative recommended mixer or command line if needed to get at the mixer controls?

At the moment I’m trying to troubleshoot my Microphone functionality, it doesn’t seem to work at all for both the built-in laptop mic and plugging into the mic jack.

TIA for any assistance,
Tony

The following was installed and configured by SuSE more or less by default

OS:
OpenSuSE 11.3, KDE 4.4.4 release 3

Hardware :
HP Pavillion dv9500
Core2Duo T7500
4GB RAM

Installed Drivers Type 10:ALSA emulation
Card config HDA Intel

Mixers Realtek ALC268

!!ALSA/HDA dmesg
!!------------------

5.658190]   alloc kstat_irqs on node -1
5.658198] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
5.658277]   alloc irq_desc for 30 on node -1
5.658279]   alloc kstat_irqs on node -1
5.658292] HDA Intel 0000:00:1b.0: irq 30 for MSI/MSI-X
5.658328] HDA Intel 0000:00:1b.0: setting latency timer to 64
5.701324] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:d


5.742586] iwlagn 0000:02:00.0: loaded firmware version 228.61.2.24
5.877205] ALSA hda_codec.c:4385: autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0)
5.877210] ALSA hda_codec.c:4389: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
5.877214] ALSA hda_codec.c:4393: hp_outs=1 (0x15/0x0/0x0/0x0/0x0)
5.877217] ALSA hda_codec.c:4394: mono: mono_out=0x0
5.877220] ALSA hda_codec.c:4397: dig-out=0x1e/0x0
5.877222] ALSA hda_codec.c:4405: inputs: mic=0x18, fmic=0x19, line=0x0, fline=0x0, cd=0x0, aux=0x0
5.877638] ALSA patch_realtek.c:1287: realtek: No valid SSID, checking pincfg 0x411111f0 for NID 0x1d
5.877641] ALSA patch_realtek.c:1370: realtek: Enable default setup for auto mode as fallback
5.890286] phy0: Selected rate control algorithm ‘iwl-agn-rs’

The following is excerpted from my ARECORD report

ARECORD

**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

Also, there are reported AMIXER controls for a mic in my Intel card (the following is exerpted from the full report), so it looks like the default setting is mute?

Simple mixer control ‘Front Mic Boost’,0
Capabilities: volume penum
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 2
Front Left: 0 [0%]
Front Right: 0 [0%]
Simple mixer control ‘Mic Boost’,0
Capabilities: volume penum
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 2
Front Left: 0 [0%]
Front Right: 0 [0%]

You could use ‘alsamixer’ which is a command line mixer. But I don’t know whats wrong with kmix sorry

Howdy,
Thx for the suggestion, since I originally posted I’ve installed every mixer available in the YAST repository.

Perhaps a clue, perhaps not… Every Analog mixer behaves the same way (doesn’t load).
The digital mixer reported a digital card wasn’t found.

As far as I can tell, according to what I posted SuSE installed ALSA and am using the ALC 268 chip, which I don’t think should be that unusual a combination.

Tony

Solved.
Found the following thread

Recording audio from file…

Of the many suggestions in the thread one was to configure the soundcard in YAST.
Opening up YAST on my machine I found that the soundcard model config was empty, although I don’t know what listed models are supported on a flyer I entered “hp”

The soundcard restarted, I immediately noticed the volume on the machine was vastly improved (although wasn’t bad originally).
Although the sound icon in the tray didn’t immediately re-appear (took about 2 minutes), I immediately noticed the new button on the volume control labeled “mixer” and how 'bout that – It launches kmixer.

Am going to investigate further now whether my microphone volume issue is also resolved as well…

Tony

Addendum.
Microphone issue solved also.

As noted earlier, in the AMIXER controls report the mic volume appears to default to zero.
Also, curiously although the soundcard is recognized as an analog device apparaently for some reason KMIXER seems to believe sound capture (including the microphone) is digital.

So, it’s one of those happy days something actually was solved…

Tony

Small update for anyone who looks up this thread.
Interestingly, initially Kmix only launched from the tray as described, launching from the menu or from BASH continued to just momentarily hang. During the hanging, you could see an item in the taskbar but after a minute or two loading gave up and the item in the taskbar disappeared.

Then launched kmix from the “Run Command” menu item, and it worked.
Only after that, THEN launching from both the menu and BASH also worked.

Weird. But now all works. Incidentally all other mixers still do not work, I assume that those mixers are specific to non-ALSA controls.

Tony