kmix volume control problem

OpenSUSE version 11.2 (Clean install)
kmix 4.3.1-3.5
KDE 4.3.1
hardware ICH6 High Definition Audio Controller and GCube Radeon HD2400Pro HDCP
(Medion computer with Radeon HD2400 Graphics card)

First of all as a new Forum member, may I say that the Forum’s help getting started with 11.2 is invaluable. I’ve now managed to get my RT2500usb wireless LAN working after many hours frustration plus I’ve managed to get my Radion Graphics card working after many more hours and cursing the ATI drivers. But now I can access the internet AND see what I’m doing… brilliant.

I’ve now hit a brick wall with kmix. I can’t seem to control the volume of apps via kmix. For example I can control the volume of Amarok if I put the curser on the Amarok icon and use the mouse wheel but it doesn’t work i.e. the volume doesn’t change if I do the same thing on the kmix icon or use the volume control on the keyboard. The slider moves but the volume doesn’t change. I’ve tried right-clicking the kmix icon to select master but the only two options I have are PCM and PC speaker for the HDA Intel mixer. The HDA ATI AMD doesn’t have a volume slider because it’s for the HDMI output.

I’m using the xine engine and HDA Intel as top preference. Pulse audio works too on the test in Sound and Video configuration, but once again no change to the volume control.

I have just done a clean install from openSUSE 11.0 with KDE3 and had no problems whatsoever with that version.

Any ideas ?


Right click show mixer window
In there go to settings - Configure Channels
Add in Master

Not sure at all, but I once solved a problem I had with sound (that was too low) by running “alsamixer” from console and raising up one of the level control that was set too low.

Thanks caf4926, but no master selectable for front speakers, only
surround,centre, LFE, PCM, side,IEC958(capture) PC speaker, capture and capture 2 for HDA Intel

Just to add some more info,the volume control on kmix and on the keyboard works fine with SMPlayer and with VLC but not with Kaffeine or Amarok, but the device preferences are set identically via Sound and Video configuration for Audio output.
In addition kmix does not control the system notification volume.


Thanks AmigaPhil, but unfortunately alsamixer gives no more options than the kmix GUI,

Are you saying that PCM does not control the volume ?

As above, PCM (Volume control on kmix and keyboard)works fine with SMPlayer and with VLC but not with Kaffeine or Amarok,I can only control the volume of Amarok via the Amarok icon in taskbar or directly on the Amarok GUI.

You know I personally dislike the new Kaffiene and Amarok and traded them both for SMPlayer. VLC, and Songbird

Taralkeda, I’m not too fond of them either, but I hate it if things don’t work >:(

There is a chance that your audio card is not configured correctly by the autoprobe of alsa, albeit that is not too likely. But we can investigate that possibility.

To do so, I need more information.

You can do that in openSUSE-11.2, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and copy and paste the following into that terminal/konsole


It will diagnose your PC’s hardware and software configuration for audio, and it will ask you if you wish to UPLOAD/SHARE the information. Select that. It will post its output on the Internet/web. And when finished it will give you the URL of the web site where the information is posted. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa ‘alsa
rpm -qa ‘pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/50-sound.conf…