kmix uses 100% of processor resources

Hello,
I have a problem with kmix, which uses 100% of my processor without stopping. And this is providing to rise of temperature above 80 degrees Celsius. The problem became actual after one of updates of 11.4 series.
Please tell me what informations are needed for You to provide me a help :slight_smile: The version of KDE is 4.6.0.

Michal.

How do know this. Better back your statement with evidence.

Thanks for reply.
I’ve checked this with “top” command and when killing “kmix” everithing backs to normal.

You could try to clean out all kinds of KMix settings:
There are the files “~/.kde4/share/config/kmixrc” and “~/.kde4/share/config/kmixctrlrc”.
And then there is the directory “~/.kde4/share/apps/kmix”.

In addition, there is Pulseaudio.
The directory “~/.pulse” and maybe the file “~/.pulse-cookie”

(All in your home folder, of course.)

Thanks!
very funny, that I didn’t think about that solution :slight_smile:

Sorry, deeste,

But there is nothing funny with Lord_emsworth advice. There could be something wrong in the configuration files and finding out what exactly is not a nice task (eve if it can be doen in a reasonable amount of time). Removing them from the users poiunt of view, loging out and back in again to let them be generated anew might help.
A complete messed up desktop can be restored to the defaults in the same way and is advised (and thankfully executed) here often.

A variant is not to delete those files, but rename them. They can then be renamed back to the original name if needed (but I guess Lord_emsworth guessed that you understood that variant yourself)

A variant may be to generate a new user and see if the problem is also manifest when this user is running (or ask other users you may have allready on the system). In this case you do not destroy anything in your “own” users environment.

On Tue, 17 May 2011 01:36:04 +0530, hcvv <hcvv@no-mx.forums.opensuse.org>
wrote:

> Sorry, deeste,
> But there is nothing funny with Lord_emsworth advice.

i don’t think he found the advice funny, but the fact that he didn’t think
of this earlier. happened to me, too. a while ago kmix used 100%
resources, just as it did with the OP, and i simply uninstalled kmix,
using alsamixer instead. some time later i thought of the option to remove
kmix conf. files, reinstalled, and since then it’s working ok. i also find
it “funny” that i didn’t think of that first…


phani.

Hm, you could be right, but why doesn’t he report then that he did remove the config files and that it worked (or not)?

On Tue, 17 May 2011 13:36:06 +0530, hcvv <hcvv@no-mx.forums.opensuse.org>
wrote:

>
> Hm, you could be right, but why doesn’t he report then that he did
> remove the config files and that it worked (or not)?
>

i understood his message that he did, but he didn’t make that clear. i
assume he got his problem solved and isn’t paying attention to this thread
anymore. not particularly nice, but not unheard of either. interest in
“the community” limited to his own needs – or he’s not connected to the
internet at all times, or his boss doesn’t approve of this type of
thing…many possible reasons.


phani.

You are of course correct, but I allways try not to jump to conclusions by assuming all those things. Being it technical (people telling stories here, bit not showing what the system did) or otherwise. Thus for me he did not say so, thus he did not do it or he thinks that we are looking over his shoulders.
And about those who never tell something that a solution helped them (and maybe even say “thank you”) you are allso correct. Why are we trying to help anyway? Sigh…

On Tue, 17 May 2011 14:36:04 +0530, hcvv <hcvv@no-mx.forums.opensuse.org>
wrote:

> …
> And about those who never tell something that a solution helped them
> (and maybe even say “thank you”) you are allso correct. Why are we
> trying to help anyway? Sigh…

because you are nice guys, i guess. and because it feels good to be able
to help someone, even if they don’t always appreciate it. and, of course,
because anybody can manage to paint themselves into a corner, and hope
that others can think of a solution…


phani.

Thanks for this. It makes me feel good again. Yes we cary on with this satisfying task, being glad with every little pat on the head. rotfl!

PS I am sure you are also one of those guys, thus it is not only “you are nice guys”.

So I found this thread, and I’m having the same problem. Advice here has fixed it (so far, only been 5 minutes), and I was using the old alsamixer trick as well strangely enough.

I only needed to remove the profiles directory and kmix is now behaving properly.

Thanks .

This helped me too. KMIX was using all available CPU (according to TOP) and I just KILLALL’ed KMIX - everything returned to normal after that. Thanks guys - albeit three years after the original query. Richard