KMix mutes microphone in openSUSE 12.3 when trying to change the input level


I’m experiencing a strange problem which looks like a bug in either KMix or PulseAudio. When I first started Skype on openSUSE 12.3 everything worked just fine. However, as soon as I tried changing the microphone input level in KMix during a test call, my audio input stopped working. After I closed Skype and started it again, the microphone input level was set to zero and increasing the input level had no effect. Only after I installed pavucontrol I was able to see what was going on. Essentially, I soon as I would touch the Skype input level in KMix, it would immediately go to zero and any further attempts to change the input level from KMix would simply keep it at zero. The only way to increase the input level is to do it from pavucontrol.

Has anybody else experienced this problem?


Wouldn’t this be better when posted in Multimadia? That is where they talk about sound, mixers, microphones, etc.

I can move it when you want.

Please do.

Thank you.

CLOSED for the moment. Will be moved too Multimedia.

Moved from Appplications and open again.

I have not seen this and I have changed the mic record levels with kmix when using Skype.

But if this is repeatable for you then I recommend you write a bug report on it, so that it can be fixed. It could be hardware specific. There is guidance here for raising bug reports: and you can use your openSUSE forums username and password on bugzilla without the need to register again.

Thanks for the reply. For me the problem is fully reproducible, both using Live CD on my Dell Inspiron laptop as well as when running openSUSE 12.3 inside VirtualBox (using ICH AC97 audio controller). That’s what made me think that the problem is not hardware specific. In any case, I will try Live CD on my wife’s HP laptop before I submit a bug report.

A bug report has bin submitted