kmix & kamix after reboot away

Suse 10.3:

It seems that kde overwrites alsaconf and/or kmix in user mode but not in root mode. Sometimes an sudo alsaconf and reboot works
sometimes not. My chipset/driver of the soundcard: intel8x0 nVidia Corporation CK804.
In many forums I found many further suggestions:
rcalsasound stop
rcalsasound start
alsactl store
reboot (warm)
rcalsasound stop
rcalsasound start
alsactl store
reboot (cold)
rcalsasound stop
rcalsasound start
alsactl store
reboot (cold)
uninstall kmix
install kamix
mknod /dev/mixer1 c 14 16
chgrp audio /dev/mixer1
chmod uog+rw /dev/mixer1
rcalsasound restart

etc. etc.

All these workarounds does not lead to a stable result.
Does anybody has an idea how to fix the problem definately? (allways having a working kmix or kamix in user mode)

Some further information about my sound system:
rpm -qa | grep alsa


hwinfo --sound

15: PCI 04.0: 0401 Multimedia audio controller
[Created at pci.301]
Unique ID: 8otl.Ruxz4biUXb3
SysFS ID: /devices/pci0000:00/0000:00:04.0
SysFS BusID: 0000:00:04.0
Hardware Class: sound
Model: “Super Micro CK804 AC’97 Audio Controller”
Vendor: pci 0x10de “nVidia Corporation”
Device: pci 0x0059 “CK804 AC’97 Audio Controller”
SubVendor: pci 0x15d9 “Super Micro Computer Inc”
SubDevice: pci 0x1211
Revision: 0xa2
Driver: “Intel ICH”
Driver Modules: “snd_intel8x0”
I/O Ports: 0xb000-0xb0ff (rw)
I/O Ports: 0xa800-0xa8ff (rw)
Memory Range: 0xbf7fc000-0xbf7fcfff (rw,non-prefetchable)
IRQ: 20 (370 events)
Module Alias: “pci:v000010DEd00000059sv000015D9sd00001211bc04sc01i00”
Driver Info #0:
Driver Status: snd_intel8x0 is active
Driver Activation Cmd: “modprobe snd_intel8x0”
Config Status: cfg=no, avintel8x0 nVidia Corporation CK804ail=yes, need=no, active=unknown

Sound works perfectly under root:

Thanks for ideas & help!

I do not understand what you mean when you state “kde over writes alsa conf and/or kmix”.

Can you say that differrently? Do you mean kmix does not run by default when kde is launched? Do you mean running kde deletes the /etc/modprobe.d/sound configuration file that is setup by alsaconf ?

Please, remember we can not hear the sound from your PC, nor can we see your PC screen.

If you have a problem with your sound, it might also help if you provided the output of a copy and paste of the following command from a terminal (note you need wget installed):

wget -O && bash

That will give you a URL. Post the URL here. Just the URL.

Also, note if sound works under user “root” but not as a regular user, this could be a permissions problem (although frankly I do not understand what problem you have). Still, did you look at adding your regular user to group audio, per the guidance here: SDB:AudioTroubleshooting - working around a permissions problem - openSUSE being careful to restart after apply that change.

The link is:

I have read that in other forums: “kde over writes alsa conf and/or kmix”.
I interpret it as follows: starting or closing of kde effects the start script or kmix and/or kamix. The effect is, that kamix or kmix do not start in normal user mode after rebooting.

Also, note if sound works under user “root” but not as a regular user, this could be a permissions problem.

If this is true, then kmix or kamix should never work under a regular user. However, this not the case. Therefore, I could not be a permission problem.

I’m wondering that many contributions of users, forums and usegroups are describing this problem (see the many different suggestions of solving) since open suse 9.0 (even in open suse v 11.1 this problem occurs) independent of the sound chips and drivers. But it seems that there do not exist a principal possibility to solve the problem of loosing kmix or kamix.

Thank you.

and ? did your sound work, or not work, when you ran that script?

and what happens, after booting as a regular user, that you type “kmix” ?

Also, booting and logging into Linux with root permissions is a very bad practise. The practise is so bad, I have a policy of NOT supporting users who do that, so let me know if that is your intention to do (log in X window as user root), as I don’t want to waste your time (nor mine).

Your first post did not make this clear. Rather than “over write”, I think what you meant to say is KDE is not launching kmix when logging on as a regular user. Or is kmix starting, and then being aborted/killed ?

The soundcard worked before I used
wget -O && bash

because a lot of alsaconf warm and cold reboots brings it to work.

Okay, but now I rebooted (after doing wget -O && bash, logged in as a regular user and kamix tells me “Did not find any soundcard.”

By the way I have uninstalled kmix because in different forums it was recommended. Then I’ve installed kamix.

Normally, I do not loggin as root. Only if I need to configure hardware or some software.

Yes kde is not launching kmix or kamix.

Definitely, the soundcard-kamix problem is still not solved.

kamix still does not work when I logged in as a regular user.
Another problem that appears when kamix can not start is that
CDROMS are not mounted automatic. K3b does not open CDROMS any more.

However, automatic mount of CDROMS was possible when kamix was running normal under a regular user.

USB devices are not mounted automic as well.

Thank you for help / ideas to solve this problem.

After all these forum tips (see first message)
nothing really works. Then I found a solution:

First check if the regular user belongs to group “audio” and “disk”. (Yast -> User administration).


  1. su
  2. cd /dev/snd
  3. chmod 777 *

These things brought kamix, kmix gamix to work
and let automount USB devices and optical devices.