Kmix Issue

I can’t peacefully adjust the sound volume. I have to wait for some time before Kmix shows up. This is rather annoying. I don’t have any Kmix related files in the /.kde4 directory, so I don’t know what’s going on. If I quit the application and try to restart it from the terminal, I get:

unnamed app(28031): Communication problem with  "kmix" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

and then

kmix(28032) context_state_callback: Connection to PulseAudio daemon closed. Attempting reconnection.

After this I can see it in its place (on the system tray), but still I have to wait for a while before adjusting the volume.

On Thu, 08 Sep 2011 20:16:03 +0530, riderplus
<riderplus@no-mx.forums.opensuse.org> wrote:

> I don’t have any Kmix
> related files in the /.kde4 directory

i very much doubt that. these files aren’t in ~/.kde4 directly, but in
~/.kde4/share/apps and ~/.kde4/share/config.


phani.

Hi,

Trust me. There’s no ~/.kde4/share/apps directory. As for the second one, it’s empty. If I don’t adjust the volume, Kmix seems to consume all my processor resources. It’s really annoying.

I have deleted the files (the kmix directory and the kmixrc/kmixctrlrc files). Same issue.

On Thu, 08 Sep 2011 20:56:03 +0530, riderplus
<riderplus@no-mx.forums.opensuse.org> wrote:

>
> I have deleted the files (the kmix directory and the kmixrc/kmixctrlrc
> files). Same issue.
>

then there’s something wrong with your audio setup. what versions of
openSUSE & KDE are you running, and which repos do you use (output of
“zypper lr -d”, in code tags please)?


phani.

Here it is:

 1 | Packman Repository                | Packman Repository                      | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_11.4/                                  |        
 2 | download.opensuse.org-Stable      | Stable LibreOffice Repository           | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_11.4/ |        
 3 | download.opensuse.org-UpdatedApps | openSUSE BuildService - KDE:UpdatedApps | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/UpdatedApps/openSUSE_11.4/    |        
 4 | download.opensuse.org-filesystems | openSUSE BuildService - filesystems     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/filesystems/openSUSE_11.4/         |        
 5 | download.opensuse.org-mozilla     | openSUSE BuildService - Mozilla         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.4/             |        
 6 | download.opensuse.org-oss         | Main Repository (Sources)               | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/11.4/repo/oss/              |        
 7 | libdvdcss repository              | libdvdcss repository                    | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/11.4/                                         |        
 8 | openSUSE-11.4-11.4-0              | openSUSE-11.4-11.4-0                    | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_TS-L632H                  |        
 9 | repo-debug                        | openSUSE-11.4-Debug                     | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.4/repo/oss/               |        
10 | repo-debug-update                 | openSUSE-11.4-Update-Debug              | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/11.4/                              |        
11 | repo-non-oss                      | openSUSE-11.4-Non-Oss                   | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/                 |        
12 | repo-oss                          | openSUSE-11.4-Oss                       | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                     |        
13 | repo-source                       | openSUSE-11.4-Source                    | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.4/repo/oss/              |        
14 | repo-update                       | openSUSE-11.4-Update                    | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.4/  

I uninstalled Kmix. I can live without it. I have alsamixer.

On Fri, 09 Sep 2011 14:06:03 +0530, riderplus
<riderplus@no-mx.forums.opensuse.org> wrote:

>
> Here it is:
>
>
> Code:
> --------------------
> 1 | Packman Repository | Packman
> Repository | Yes | Yes | 99 | rpm-md
> |
> http://packman.inode.at/suse/openSUSE_11.4/
> |
> 2 | download.opensuse.org-Stable | Stable LibreOffice
> Repository | Yes | Yes | 99 | rpm-md |
> http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_11.4/
> |
> 3 | download.opensuse.org-UpdatedApps | openSUSE BuildService -
> KDE:UpdatedApps | Yes | Yes | 99 | rpm-md |
> http://download.opensuse.org/repositories/KDE:/UpdatedApps/openSUSE_11.4/
> |
> 4 | download.opensuse.org-filesystems | openSUSE BuildService -
> filesystems | Yes | Yes | 99 | rpm-md |
> http://download.opensuse.org/repositories/filesystems/openSUSE_11.4/
> |
> 5 | download.opensuse.org-mozilla | openSUSE BuildService -
> Mozilla | Yes | Yes | 99 | rpm-md |
> http://download.opensuse.org/repositories/mozilla/openSUSE_11.4/
> |
> 6 | download.opensuse.org-oss | Main Repository
> (Sources) | Yes | Yes | 99 | yast2 |
> http://download.opensuse.org/source/distribution/11.4/repo/oss/
> |
> 7 | libdvdcss repository | libdvdcss
> repository | Yes | Yes | 99 | rpm-md |
> http://opensuse-guide.org/repo/11.4/
> |
> 8 | openSUSE-11.4-11.4-0 |
> openSUSE-11.4-11.4-0 | Yes | No | 99 |
> yast2 |
> cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_TS-L632H
> |
> 9 | repo-debug |
> openSUSE-11.4-Debug | No | Yes | 99 |
> NONE |
> http://download.opensuse.org/debug/distribution/11.4/repo/oss/
> |
> 10 | repo-debug-update |
> openSUSE-11.4-Update-Debug | No | Yes | 99 |
> NONE |
> http://download.opensuse.org/debug/update/11.4/
> |
> 11 | repo-non-oss |
> openSUSE-11.4-Non-Oss | Yes | Yes | 99 |
> yast2 |
> http://download.opensuse.org/distribution/11.4/repo/non-oss/
> |
> 12 | repo-oss |
> openSUSE-11.4-Oss | Yes | Yes | 99 |
> yast2 |
> http://download.opensuse.org/distribution/11.4/repo/oss/
> |
> 13 | repo-source |
> openSUSE-11.4-Source | No | Yes | 99 |
> NONE |
> http://download.opensuse.org/source/distribution/11.4/repo/oss/
> |
> 14 | repo-update |
> openSUSE-11.4-Update | Yes | Yes | 99 |
> rpm-md | http://download.opensuse.org/update/11.4/
> --------------------
>

hm, i don’t see anything that makes me think it could be cause for this
problem; i was suspecting some obviously wrong repo. in the mix, which i
don’t see.

as far as i know, you’re not supposed to leave the libdvd.css repo
enabled, but i’m not sure if this applies to the version from
opensuse-guide.org, too. it can also be dangerous to have many
non-standard repos enabled, but if everything used to work with this
configuration, that shouldn’t be the reason either.

to make sure that not some incompatible package(s) slipped in somehow,
you can look at the result of “zypper ve”, if that complains about any
dependencies missing.

do you remember what you did before kmix started to misbehave? was that
right after an update? if yes, you can find out from /var/log/zypp/history
what the exact changes were.

personally i’m running KDE 4.7.1 and don’t have these problems, and don’t
remember having had them under 4.6.0. something’s wrong with your audio
configuration, but at the moment i’m only guessing at the cause. usually i
get my sound working after fiddling with the following settings, perhaps
also pavucontrol, which is useful for configuring pulseaudio.

  • when you open yast -> sound configuration, in the right corner there
    should be a button saying “Other.” that contains a link to “Pulse Audio
    Configuration.” dis- or enabling pulse audio might help;

  • then there’s multimedia -> phonon configuration under systemsettings ->
    hardware, where you can change audio devices and backend configuration;

i hope others with more experience & knowledge can help you bettter with
this…


phani.

Thank you for helping me out, phani. I did a zypper re and refreshed my repos. I don’t know if there’s anything I can do about Kmix. I’ll just stick to alsamixer for the moment and wait for a new openSUSE to come. :slight_smile:

[QUOTE=phanisvara
>

  • when you open yast -> sound configuration, in the right corner there
    should be a button saying “Other.” that contains a link to “Pulse Audio
    Configuration.” dis- or enabling pulse audio might help;

  • then there’s multimedia -> phonon configuration under systemsettings ->
    hardware, where you can change audio devices and backend configuration;


phani.[/QUOTE]

I have been having this same issue for the past few days. I started doing some video and sound editing earlier this week, and needed to install the lame library file, and I did a complete software update also. After that, my kmix started having some latency in showing the mixer panel.

I followed phanisvara’s suggestions and so far it is working correctly, after a reboot.

I don’t know if the software update, or lame install caused the issue, or if my editing activities somehow change the sound configuration, but the fix is as simple as suggested.

Thanks for your post, phanisvara.

Now I have discovered that the Lives video editor requires pulseaudio to be enabled for certain functions. So, I’ve enabled it and completely removed Lives, and the ~/.lives config file, then reinstalled it to use pulseaudio. Kmix has so far been working correctly with pulseaudio, but I’ve left the phonon changes as suggested. The problem may have been an errant audio device definition in phonon. I don’t exactly know what caused the Kmix problem, but I’ve gotten everything working to my liking. I hope this might help others with this problem.

I’ve finally removed the content of the “profiles” directory in apps/kmix, and now everything’s fine, so dozens of thanks, guys :slight_smile:

Now my processor is tired by too much of plugin-container (firefox). I installed google chrome, but it’s still heating.