kmix doesnt start since upgrade to kde 4.5

Hi,

Running openSUSE 11.3, installed a month ago, and the only change I did from the default install was to update to kde 4.5 (along with usual updates).

Since the upgrade, kmix doesn’t start. When I click it, I see the bouncy kmix icon, and a new slot is opened on the task bar which reads ‘kmix’, but it shows nothing, and after a minute or so it disappears, along with the kmix bouncy icon.

No error is given, so I tried to run from shell. This time when I try ‘kmix’ it does nothing at all (doesn’t appear in ‘jobs’).
However, when I try ‘sudo kmix’ I get this error :

unnamed app(7668): KUniqueApplication: Cannot find the D-Bus session server:  "/bin/dbus-launch terminated abnormally with the following error: Autolaunch error: X11 initialization failed.
" 

unnamed app(7666): KUniqueApplication: Pipe closed unexpectedly.

I’m not sure if that’s helpful or not…
Besides kmix, sound works normal, and I can adjust sound volume with the volume indicator on the task-bar. Hmm… just noticed that the kmix icon is greyed when I right click on the volume indicator.

I’m on an HP pavilion DV7 laptop, 64 bit, 4GB memory, nVidia Geforce 9600M.

Any help will be appreciated :slight_smile:

Ori

Right-click in the system tray space, pick Configure System Tray / Settings, check the tabs in the settings, kmix should be checked, it’s icon should be set to ‘always show’

I tried changing the icon to ‘always show’ but it doesn’t have any effect.
But even if the icon was there, would this solve the problem of kmix failing to launch?

thanks,
Ori

I suspect it’s running, you just can’t reach it, since it’s icon does not show up. We’re going to find out…:slight_smile:
Right after the start of the KDE desktop, open a terminal window and do:


ps -ea  |   grep kmix

This looks for “kmix” in the output of “ps -ea”, which shows all processes. It should show something like this:


 8250 ?        00:00:00 kmix

Please report the output here

Issue solved.

my output :

ori@linux-wxkd:~> ps -ea | grep kmix
 2586 ?        00:00:04 kmix
ori@linux-wxkd:~> 

I guess you are right, because I found out how to access it!
After clicking on the volume indicator, there’s a ‘mixer’ button on the bottom (missed it before).
Clicking that open kmix.

Thanks alot!