Kmix boots muted.

Kmix is always muted when I boot up. I also get a notification pop up that some sound device is not working, so the system is falling back to ??? The notification flashes by too fast to read properly, but it seems to me that no matter which one I set up as the primary in Configure Desktop → Multimedia → Device Preferences…, that is the one that fails.

I also have Kmix configured to show in the system tray and it doesn’t until I go into the application menu and start it or start it from a command line. Once I unmute it everything sounds fine.

So how can I get Kmix to boot unmuted and show up in the system tray?

I have suddenly started to get the notification about falling back to PulseAudio but the sound is OK.

Not sure what the problem is with KMix as it appears in the system tray unmuted every time. Have you tried ‘Add to Panel’ from the menu?

Since applying recent kernel update and a pulseaudio update, I get the problem of kmix muted on reboot. No notifier seen. Kmix in system tray from start, unmuted sound works.

However on my testing partition of 11.2 milestone2 updated from factory butb different kernel, I had the same problem just with Kmix muted. I made a change to sysconfig, experimenting, reset the change but it’s damaged something. Now on that system I get the problem more similar to you but without notifier yet.

I expect these problems on the factory test system, but on 11.1 kernel update it’s just shambolic. :frowning:

This was a known bug. I believe a number of users have reported this. There are a more than a fewthreads here, where users have posted solutions that worked for them:

Yes, it was after the kernel and PulseAudio update that this started. Strangely this morning Kmix was not muted, but I got the notification and no start up sound. I ran a timer widget right after boot and it chimed after the 30 sec. I set it for, so KDE sound works in spite of the notification.

The Kmix icon still did not show up in the tray.

BTW, this is a KDE 4 desktop on Suse 11.1

Thanks for the threads. I had already checked them out.

This is very strange! If I select YaST>Hardware>Sound and click on nothing further, the Kmix icon in the system tray is immediately unmuted.

BTW, I am on KDE 3.5.10 on 11.1, and PulseAudio is not enabled in YaST>Hardware>Sound>Other>PulseAudio_Configuration>

Please note this is also part of the OP’s problem (may have since unwittingly been highjacked)

I can’t explain, can anyone else? :question:

I take it that trying to save the “unmuted” settings via kmix did not help?

Just tried saving the KMix settings even though they hadn’t changed, and rebooted. No different, KMix still muted on reboot. (11.1 KDE 3.5.10). Also, note the YaST behaviour in amy bove post.

I don’t believe this is a KDE problem because it also appeared first on my Factory updated 11.2 milestone1/2 partition, that is at KDE 4.3beta.

oldcpu, to be clear it was unmuted settings I saved that did not help.

If you think it might be alsa instead of kde, you could try the guidance here:
Troubleshooting Linux Audio, Part 3a | Linux Journal
which is to setup your sound/mixer the way you want and then with root permissions run: alsactl store

Thats just a very speculative suggestion of something to try on my part.

Ok, I understand your comments. The sound does work for now, it always has OOTB. It’s just this KMix mute that is inconvenient, nothing really broken yet.

I can’t be sure its not KDE. On 11.2 since I interfered in sysconfig, I suddenly got long delays before KMix started and lockups, even though I reset the boot parameter I changed. I wish I had left it with just the inconvenient mute. It appear like Development have brought the 11.2 problem to 11.1 either with kernel or pulseaudio change.

Two things changed here on 11.1, kernel update and pulseaudio update. I am not sure what config files get changed with such updates, but I am going to search logs and files that may have changed before I attempt to re-configure anything. Then I will investigate your suggestion - it will be useful experience even with no fix.

That may take a while, so if you hit upon anything else, please post it here.

Thanks oldcpu.

I also noticed that my sound was muted after the pulseaudio update, but it’s my master channel that’s muted in the mixer, not the applet in the panel. This is for openSUSE 11.1 with KDE 4.3 beta 2.

In Milestone 2, the KMix applet in the panel is always muted after a reboot. (Known bug already reported)

Did you install kernel and P/A updates separately?? I wondered how you were sure it’s the P/A update (libpulse0 I think) that caused it. The kernel update also updates several P/A modules, according to my zypper log.

The muting of the KMix applet in the panel is shown by a diagonal line through it, but it is the master channel that is muted, and only that channel. Unmuting that channel, unmutes the applet.

Both kernel and pulseaudio updates were available at the same time through the suseupdater applet yesterday, and that is how I updated.

On my machine, the KMix applet in the panel shows volume at 100% even when the master channel of the mixer is muted.

Ok, installed the same as me. I wish I had installed them separately and checked inbetween, then I could be sure which one caused it. In my zypper log, libpulse0 installed first.

The difference in applet is KDE 4.3 versus my 3.5.10. Now I have 4.3beta on 11.2 and the same muting problem (also when it was 4.2.2). On 11.2 the icon doesn’t have the diagonal line, but a very small x beside it that is harder to see.

I updated Milestone 2 to KDE 4.3 beta 2 today also. I rebooted and it took 6 minutes for the KMix applet to show up in the panel. The applet shows the sound is muted and the mixer shows that the master channel is muted.

Clicking on the applet and unmuting unmutes the applet and the master channel at the same time. In 11.1 the applet isn’t muted but the master channel is.

I can confirm same problem as you describe on 11.2 with KMix taking 6 or 7 mins to arrive in system tray. During this time if I tried to start other apps e.g. dolphin, it also waited to appear until KMix had appeared muted. It took about 3 mins after the panel appeared for the updater and the notifier to appear.

I seem to be at this KDE level now on 11.2: Version 4.2.88 (KDE 4.2.88 (KDE 4.3 >= 20090527)) “release 3”

I did a fairly large update from factory on 5 June. On 10 June only one package pciutils-ids updated but after the problem manifested. After the update on the fifth there was no problem, until the next reboot on 10th when this problem started. Something in the large update on the 5th caused it. PulseAudio must be a prime suspect given its track record here.

I skipped the June 5 update. I updated today and I’m running KDE 4.2.90 release 139.

I also filed a bug report about KMix being muted in openSUSE 11.1.

i have the same problem,but i fix it by open the mixer window and check the headphone mute box .

Well done for 11.1. It’s a bit of nuisance, but sound works on mine. I am now on KDE4.3beta2. My mirror must be a bit behind yours. Just updated, I am on 11.2 Milestone 2 - 2.6.30-rc8-6 (pae) . I wanted to see if KMix muted problem was cleared. Oh, before the update when I booted today, the 6min launch of KMix had reset to normal but still muted.

With this update its not muted, it’s totally ****ed. I had no sound and no Kmix on reboot. Started from terminal gives errors and says it probably crashed – no kidding. Yast>Hardware>Sound>Other>Volume told me that Master was set at zero, so I set it and had sound. But no Kmix on trying it again – same errors.

Will take this over to the prerelease forum.