Kmix and the microphone

My wife had a bit of rant at me today. …

Sometimes I think, in her eyes, I embody anything and everything that is wrong with Linux. So if something does not work when she boots to Linux, its invariably my fault. I think she believes I must have been the person who deviously >:) was urging the developers to throw some nasty curve in the interface, to fool the unsuspecting MS-Windows user, who for one reason or another finds themselves faced with a Linux desktop. And because of that assumed deviousness, I am automatically guilty. >:( < sigh > …

… anyway, she was trying to talk to some relatives overseas tonight, using some Windows telephone software, where that software does not work in Vista, but it does work in WinXP. WinXP in our family laptop is running in Virtual Box under openSUSE and the mic under kmix in openSUSE KDE-3.5.10 was not working for her.

It turns out she tuned the settings wrong in kmix, and stubbornly refused to believe she had them wrong. Even when I corrected them for her, she refused to believe the settings I put in place were what caused the mic to suddenly start working. Only after 20 minutes of trying every possibility, did she finally concede I set the correct settings. The fact that I had a functional mic on my side was the only factor that convinced her. …

But I had to concede in the end, after having my ear bent by a rant, that she had a point about kmix.

Currently, in kmix, if a mic setting is muted, the colour of the small mute circle is a dark red. If the mic is unmuted, it is a bright red. From my perspective the dark red means the light is out, and the bright red means the recording is taking place. From her perspective, any red indicates the recording is taking place, it does not matter if it is bright or dark. If red, it should be recording. She thinks then there is no recording, it should be a dark grey or some other colour.

In the end, I had to agree with her. The dark red convinced her the mic was not muted, when in fact it was.

Now I have to figure out who to contact about kmix, to see if they will consider changing the mute indicator colours. :\

Happy Families!

I get a small red x for mute
and green ))) for active

That was on Mic not master.

Is that with the kde4 kmix ?

Yep. kde4 for sure.

Ok, thanks. I can see kde4 is going to have to go on the family laptop to prove to the wife she is being listened to. :slight_smile:

Like this
ImageBam - Fast, Free Image Hosting and Photo Sharing

Thats the mic? or the speaker?

Its the mic “icon” appearance that has my wife perturbed.

The actual image never changes whatever it’s on, mic, speaker…

caf4926, I think you are not looking at the area that my wife was refering to.

I flashed up my sandbox PC, and went to the openSUSE-11.1 KDE-3.4 partition on it. Here is what the kmix looks like on that PC, when it is setup to record:

No colours in KDE4. Just grey boxes. Either set to mute or record. As it turns out it does not use colour coding.

Its rather strange yours is so different. Surely your mixer MUST have more detailed controls?

I’ll have to post a KDE3 mixer pix, so you can see the difference.

Lee, yes. I was just thinking you were refering to the icon in the panel not the expanded setting. I only have master and PCM enabled, but I switched some others on and did a shot:](
I don’t seem to get the little red circles as you describe them. But I find nothing difficult about it.

caf4926, here is a kmix pix from KDE-3.5.10.
Now to me it was intuitively obvious that the bright red is active, and the dark red is muted. But my wife does NOT see it that way. She thought they were both active if red, and that it would go grey or some other colour if not active.

She even tried to argue that bright red meant muted!

In the end I had to agree the colors could have been chosen better.

I see. Clear now.
I tend to agree with you, seems logical - Light ON = Sound ON