kmail5 fails to start

I’ve just upgraded form 13.2 to Tumbleweed (a new installation rather than an update). After the installation, I started kmail5 from the start menu, and was able to configure it, import archived email, and send and receive mail. However, after I quit the application, it wouldn’t restart, nor would it start after a reboot. I uninstalled, rebooted, and reinstalled it, and it started OK, but on quitting, once again it failed to start. Anyone have a solution for this?


Try invoking from a console instead of the menu item. To determine the exact command for invoking from the console inspect the menu item properties.

When you invoke from a console, hopefully any failure will display a descriptive error.


I suspect it’s already running… check the triangle in the systemtray area.
If it indeed is, I’d still consider it a bug. Trying to start it again then should open the kmail window.
Don’t see this here though. No matter whether I actually close kmail5 from the menu, or just send it to the systemtray

I did this, using the command kmail -qwindowtitle %c %u (which I got by right-clicking on the icon, as suggested). I was just returned immediately to the command prompt, with no shell messages (and no kmail, of course). I’ve also tried stopping Akonadi and deleting its configuration files (following the Kmail handbook’s instructions for a “Clean start after a failed migration”), removing kmail, restarting, installing kmail again and reconfiguring it, with the same result–I was able to open kmail from the Start menu and configure it, but once I quit, it wouldn’t restart.

It’s not very useful to add “-qwindowtitle %c %u” when running it manually. That’s stuff that gets replaced automatically when run via the application menu… :wink:

I was able to open kmail from the Start menu and configure it, but once I quit, it wouldn’t restart.

Try to kill it.
It won’t start if it’s already running, and it may fail to quit for some reason.

I am aware of a bug report where it won’t quit if “Empty trash on exit” is enabled.
Also, it may continue to run in the system tray (this can be configured), check that there’s no kmail icon there, maybe hidden.

Hurrah! “Empty trash on exit” was checked. I deleted and reinstalled kmail, started it, went to Settings and unchecked it. And after I had quit, I was able to reopen it. Thanks very much for your help.

You’re welcome.
I’m glad it works now again. :slight_smile:

But it shouldn’t have been necessary to uninstall and reinstall kmail, that’s the “Windows way of solving problems”, and normally doesn’t help much in Linux.
As you already noticed earlier… :wink:

No doubt it isn’t kosher. But the only kmail I could get to start was a freshly installed one, so to get to the Setting menu I had to reinstall to get a running kmail. No doubt there are ways to reconfigure kmail without starting it, but I don’t know what they are. I do know how to reinstall an application, so I did.

The point is that a reinstallation won’t change your user settings.
If the problem is caused by the settings, a reinstallation won’t help at all.

What probably did help in your case was that kmail wasn’t running any more, therefore you were able to start it again. (as mentioned, kmail refuses to start if it is already running)

But just killing it or logging out and in again (or reboot) would have achieved the same. You apparently did that anyway and that “fixed” the problem, not the reinstallation.