Kmail3 plus KDEPIM3 on 12.3 gone well so far but for one file from11.4

I copied files directly from my old machine following these suggestions

KMail/FAQs Hints and Tips - KDE UserBase Wiki

Everything has come across including filter setting and identities. Should be possible to import the old address book as I exported it from the old set up. The only part that hasn’t is the email accounts as KDE4 started using a new method via the mailtransports file. I am not sure where and how Kmail 3 kept these and wonder if anyone knows? This might save typing them all out again.

In case others want to do this
KDEPIM3 installs Kmail in /opt and the usual user directories. Desktop files can be found in /opt/kde3/share/applications/kde. YAST doesn’t create menu entries or a desktop icon. The kmailrc file refers to the kde4 directory. That has to be changed to kde. Apart from that the directory structure mirrors 11.4. I also uninstalled Kmail4 first.

If some one want to change over from the more recent mail storage methods it looks like there is a problem as the import function in Kmail3 doesn’t seem to work. I just copied the entire mail directory across and then the specific files mentioned in the link.

Only problem so far is that the folder view setting adjustments don’t seem to be retained. As it opens it looks like the folder structure hasn’t been retained but it’s just that the column widths aren’t appropriate.


Couple of more things

When installed I copied the desktop file to the minuscule desktop panel and all worked for a while and then stopped working. I replaced the copied desktop file with a simple link to the real one. All ok but the icon wasn’t very nice. I also found that while I could save an attachment in an email I couldn’t launch one. Following a reboot this morning, nice icon and attachments launch. Also the link has turned itself into a desktop file.

rotfl! The icon goes green when launched and of course stays green when the app is closed. No method of disabling the greening. A hang over from kde year dot. It doesn’t know when none kde apps have been closed or when they have actually launched - the later causes the spinning thingy of old on every launch that stays there well past the time it takes the app window to appear.


Yet another

The folder layout view has been mostly retained. I can now see folders and unread which is how I usually have it.

When KDEPIM3-Dev is installed the mail import facility pops up when import is clicked… I thought this might be the case. It handles
Evolution 1x and 2x, Kmail, OSX,Opera,Sylpheed,Thunderbird/Mozilla local, The Bat, Outlook Express, Pegasus Mail, Mbox and Plain Text.

Also just allowed it to receive one of my email accounts. 66 mails in something under 3 secs. Mostly dreaded html so not small. All filtered to various folders correctly. My ISP varies on email speed so it may be quicker than this at times.

Seem KDE3 email should be called Kmail 1 so the thread title isn’t correct.


>:( Having worked several times it now wont connect to the mail server - nothing has been changed either.

The error message is

The server said: "[SYS/TEMP] invalid mailbox directory"

Any one have any ideas? Restarting KDE didn’t change the problem.

Looks like my monitor has to go on the old machine again to check account settings but I’m pretty sure they are correct.


It’s now working again for no obvious reason so I suspect my email server was down.


Looks like it was the server.

There was one other problem. Arrival dates were not displayed. Fixed in configure by selecting any of the available date formats. Once that has been done any of the others can be set including the default which didn’t display a date.

The custom date format incantation pop still works as well via shift F1