KMail2: Moved Messages Reappear in Mailbox as Unread

I have a local mailbox with mbox format and move read mail to archive folders. Upon arrival of new mail the already moved mails appear again in the mailbox and are flagged as unread. How can I fix this?

Try to change the compact frequency in the mbox resource configuration, and the locking method.
(Settings->Configure KMail->Accounts, select the mbox resource and click on “Modify…”)

Probably another program overwrites KMails changes, or KMail actually hasn’t synchronized the changes.

I already checked compress after 1 message and have a procmail lock file. In the opened terminal windows I get the message ‘You have new mail’, but I am not aware of any program modifying /var/spool/mail/karl

Support of Kmail2 for mbox format is extremely buggy. I am circumventing problems by using a filter which moves incoming mail (mbox format) to a Maildir folder.

Well, there have been some changes/fixes recently, so it might work better in 4.13.
But I can’t tell really as I don’t use mbox.

When upgrading to Tumbleweed KMail 5.3.0 fails to compact a mbox file the message being: Can’t load mbox file (actually Die M-Box Datei kann nicht geladen werden)

karlmistelberger wrote:

>
> When upgrading to Tumbleweed KMail 5.3.0 fails to compact a mbox file
> the message being: Can’t load mbox file (actually Die M-Box Datei kann
> nicht geladen werden)
>

I’m having similar issues trying to update from 13.2 -> 42.2. The issue
with kmail appears to involve updating with a /home that contains kmail2
message files while 42.2 (and Tumbleweed) moves to kmail5. I haven’t
managed to find a completely successful workaround just yet but I do recall
a couple of other post to these forums about migration problems there so a
search of older messages over the all the message groups, especially the
install-boot-login forum, might be the answer. I seem to recall someone
posting a work-around there a couple of weeks back but I haven’t gotten
around to searching for it - yet :wink: