Kmail shows "Ik" instead of the e-mail address of the owner's address

My wife and I both use Kmail 18.12.3 on openSUSE 15.1 on different computers.

My wife complains that, wherever her e-mail address should be in mail headers, this is replaced by the string “Ik” (which is Dutch for “I”).

I do not see this in my case, thus it must be able to switch off this “feature”. But I can not find it anywhere.

The only difference between the two systems as far as I can think of is that mine is upgraded from one of the 42.n versions, version by version to the present 15.1, while hers is a fresh 15.1 installation.

Do others see this?

Yes, Leap 15.1 did just that – with Leap 15.2, the behaviour has been changed, back to the earlier behaviour: the e-mail address of the relevant Identity is displayed (once again), instead of “me” …

  • By the way, with Leap 15.2 other behaviours have also been changed – take a look in the “Modules” section of the KMail set-up to turn them back on again …


Thus this is typical 15.1. And I personally do probably not get it because my Kmail configuration is older then 15.1. But that means that there is somewhere a place where this can be switched. How else can it be that I do not have this “feature” switched on? I could not find it browsing the Kmail settings (and also not looking in the Kaddressbook settings.

I am glad it is off again in 15.2 (we will go there sometime the next months I assume), but then a new question arises: will it then be switched off only for new installs, or also for the existing 15.1 configurations? Maybe I have to wait for a working 15.2 to check that. :frowning:

I also do not quite understand how it works. She has another e-mail address with the same provider, but mails send to that e-mail address show the used address and not Ik. Why the one does and the other not? Again, I hope we can forget this all and simply wait until it is gone.

BTW, I can not find a Modules setting for KMail in 15.1. Is that correct?

It was at the bottom of the list of setup sections – with Leap 15.1 it may well have been included in “Misc” or “Extras” sections.

  • It may also be named “plug-ins” or something similar …

Possibly due to the selection of the “standard” identity but, I didn’t bother to change anything to see if that was the case, or not …BTW – I currently have 6 identities and their associated e-Mail accounts at my ISP, activated on this system …

I have "Plug-ins in the Kmail settings, and there are a few checked there, some of them can be configured. I walked through them, but I could not find a suitable parameter.

Never mind, do not spend much energy on it anymore. The wife (and I) will be satisfied knowing that it will be a thing of the past in the near future. We can live with it.