Kmail not storing passwords

In my recently installed openSUSE 11.4 system I am using Kwallet to store all of my private passwords and also those associated with my Kmail accounts. All of these passwords appear correctly in Kwallet, but it seems there is a problem with Kmail accessing them.

Whenever I start a new session, Kmail loads first and is followed by Kwallet. When Kmail then tries to do its first mail retrieval it stops and asks for the account password. I type this in and then Kwallet requests its administrator password. Once I type this in, my mail is downloaded and I get no further request for the passwords during that session.

The same thing happens when I attempt to send my first email of the day. I get a Kmail request for the SMTP account password.

I’ve tried changing the Kwallet settings so that it doesn’t close when unused for a period, or when the screensaver kicks in, but this (predictably) has no effect. In the Access Control screen, both KDE Wallet Manager and Kontact are shown as ‘Always Allow’ and I can see no other settings in either Kwallet or Kmail which are relevant to the problem.

My guess is that the problem occurs because Kmail starts up ahead of Kwallet and therefore doesn’t load the passwords initially. But that may be a red herring as I’m not familiar with the way Kmail and Kwallet interact.

I have the same setup and don’t get this problem; have a look at your Account settings in KMail and see if you have ticked all the right buttons.

Kmail account settings look OK. The passwords have been entered and the ‘Store Password’ box ticked for both POP and SMTP.

Maybe I misunderstood this; do you automatically start KMail? I start KMail manually and also use Ctrl-L to fetch. Then KWallet appears. I never get a request from KMail itself. However long I leave KMail open, it never asks me for the password either to fetch or send. If you are starting automatically, I wonder if KMail assumes KWallet is not available for the whole session.

At the moment, Kmail is a start-up application, so yes, it does fire up automatically when I start a session. I will try removing it as an auto start-up and see if that makes a difference.

Maybe I should also clarify that once I have manually entered the POP3 and SMTP passwords, Kmail never asks for then again until I start a new session.