Kmail keeps adding domains to mails


this is probably something stupid… but I have been using kmail for quite some time now without any issues. However, out of the sudden it would return a mailer daemon for any mail I sent. Doing some research, I noticed that kmail adds the domain @benbu to every outgoing mail, making it Obviously this leads to the error, but I have not made any changes to my system recently. The domain has been that, ever since I installed openSUSE, because I did not like the default linuxy234 stuff…

There is a default domain option in Kmail, within the Identity settings, which shows @benbu as default domain. However, I cannot delete it, as it will automatically restore. If I change it to something else, the issue is the same with just another domain… changing it to gmail, will result in the mail being sent to

Now, this would not be an issue, if everyone had Gmail. I would just leave the part after the @ blank. However, I gotta send mails for business and myself to many people and many different address, so I would be happy about a way to turn this off.

Thanks in advance,


Now that was embarrassing. I did not see the grass on the lawn.
The issue was that the mail address I tried to send my message to, did not include an @ sign… :shame: