Kmail KDE displayed mail header format

Hi, this may seem trivial but, is there a way to set the default header display format when you open a mail message in k-mail?

It always opens on the all header format, I would like to set it to default to the enterprise header format, I just don’t seem to be able to see where to set that choice as the default!

Ummm, help!


try editing the file

change the line, header-set-displayed=whatever to header-set-displayed=enterprise

back up the kmailrc file first
at least this worked for me to display standard headers

Thank You!

You would not happen to know, why there is no way to set this from the user interface would you, seems kind of strange!

Thanks again.

Hi, I had to change the one under that from plain, to
header-style=enterprise, to get the nicely formatted header

ummm, still think it’s strage there is no way to set that from the actual interface!

I don’t know why you can’t change the header settings within settings/configure kmail or something. I could not even find any documentation about changing the header settings, but discovered this by trial and error.
Thanks for the tip about header-style.

From the menu choose View->Headers.

Seems that that option is not persistent. It only makes the change one time for one email.

It is persistent. Please note that there is a lot of development happening to kmail/kontact for the next release.
I am on:
kontact 4.3.0 pre
kmail 1.11.90

OK, the results I get are with KDE 2.2.2, kmail 1.11.2. If you open a particular email, the view menu has a header option which is not persistent. The view menu on the main page has no such option. I will see if I can upgrade kmail. Thanks for the info.

The latest kontact/kmail will be brought in along with KDE updates.