kmail has double folders after import

I installed Leap 15 on a new SSD. I used the pim import tool to import my messages from the old drive. (KMail was not running.) Now the list of folders is doubled. The image shows the situation:

I tried to move some of the subfolders from the bottom list to the inbox at the top. It looked like it worked at first, but then those folders reappeared in the bottom list as well with the same messages in them. Clicking on a folder sometimes makes the list rearrange itself, so I have to chase the folders around to open them. How can I fix this?

Try moving just the contents of each folder and then delete the extra ‘local folders’.

That helped because I could remove some of the extra subfolders, but I can’t delete Local Folders. The delete option is grayed out (for both of them). It will let me rename them, but they still can’t be deleted, and the list still bounces around.

Something else I tried: I found out that ~/.local/share has a file named akonadi_maildir_resource_0, which looks fine, but it also had folders named 0 and 1, each with akonadi_maildir_resource_0 in them as well. That looked suspicious, so I moved 0 and 1 out of .local/share and restarted akonadi for good measure, but that had no effect on KMail.

Looking at your KMail folder names, there’s the new “Local Folders” (the one with the blue envelope) and an imported “Local Folders” (the one with the network drive icon) which, unluckily, has been imported to the root – located in “~/.local/share/” …

Take a look in “~/.local/share/” and you should find the following directories related to the Leap 15 KMail “Local Folders”:

  • “~/.local/share/local-mail/” – containing the directories “cur/”, “new/” and “tmp/” and, possibly, the directories “inbox/”, “outbox/”, “sent-mail/”, “trash/”, “drafts/” and “templates/” – each with “cur/”, “new/” and “tmp/” directories …
  • Also, possibly, “~/.local/share/” – containing the directories “inbox/”, “outbox/”, “sent-mail/”, “trash/”, “drafts/” and “templates/” – each with “cur/”, “new/” and “tmp/” directories …

The file, or directory, “akonadi_maildir_resource_0” is suspicious – that naming convention is usually reserved for the Akonadi configuration files located in “~/.config/” – please check the contents of “~/.config/akonadi_maildir_resource_0rc” and, in particular the value of ‘Path$e]=’ – it could (should) be: “$HOME/.local/share/local-mail” but, in your case it may be “$HOME/.local/share/akonadi_maildir_resource_0”.

Whatever, without any of Kontact or KMail executing, from a KDE Konsole Window, execute the following:

  • “akonadictl status” (check the Akonadi status, it has to be "running
    "). - “akonadictl fsck”
  • “akonadictl vacuum”

Restart Kontact or KMail.

In the KMail GUI:

  1. Select everything in the “imported” (the one with the “Local Folders” network drive icon) “inbox” folder – mouse click, <Ctrl-A>, <Ctrl-.>, <Ctrl-A>;
  2. Press and hold the “shift” key and then with the mouse move everything to the “installation” (the blue envelope “Local Folders”) “inbox” folder;
  3. Move the “gmail”, “SWS” and “Wesnoth” folders in the “imported” “inbox” folder to the “blue envelope” “inbox” folder in the same way;
  4. Move all the content of the “imported” “sent-mail” folder to the “installation” “sent-mail” folder;
  5. Set up the Spam filter for the new installation;
  6. Move the “imported” “spam” folder contents to the Spam folder of the new installation;
  7. Delete the empty “imported” folders and the “imported” “Local Folders”.

Be aware that, Akonadi may need a few minutes to get the e-Mails moved over to the new installation’s folders – watch the status being indicated bottom left in the KMail status bar at the bottom of the KMail window …

And when you’ve finished, close the KMail, or Kontact, window and execute the “akonadictl fsck/vacuum” commands once again …

“~/.local/share/local-mail/” contains three empty folders.
I don’t have “~/.local/share/”.
“~/.config/akonadi_maildir_resource_0rc” does in fact contain “~/.local/share/akonadi_maildir_resource_0”. That folder contains “inbox/”, “outbox/”, “sent-mail/”, etc. and my mail. I suppose that’s unlucky too.

I got all the folders moved oven in the KMail gui already (See my previous post). I did “akonadictl fsck” and “akonadictl vacuum”, and opened KMail. But, I still can’t delete “Local Folders”–either of them. The delete option is grayed out. So I have two Local Folders, one of them empty, and a messed up configuration. Can I fix it? Can I just delete some files and re-import my mail, or should I delete all the components of pim and start over? Can that even be done? What would it include? How would I avoid getting unlucky again?

I’m trying to do my work with webmail at the moment because I can’t trust KMail, and it’s making me very unhappy.

The “~/.local/share/” appears (automagically) once a reasonable number of e-Mails of a reasonable size have been stored in one of the folders within the KMail “Local Folder”.

For whatever reason, your Leap 15 KMail2 has decided to use “~/.local/share/akonadi_maildir_resource_0” as the directory for the KMail2 “Local Folders”.

I have a Leap 42.3 Test user here which I have re-initialised – removed all the user’s directories and files and then reinstated only those files and directories in “/etc/skel/” – in other words an absolutely “fresh” user … After a “first-time” KDE log in and then log out, I kicked off Kontact for a “first time” run and used the Wizard to setup the user’s e-Mail account with valid credentials. KMail2 version 5.5.2 created a “Local Folder” directory “~/.local/share/local-mail/”. “~/.config/akonadi_maildir_resource_0rc” contains only:


I have a vague recollection that, during the Leap 15 beta testing I did notice that, the Leap 15 KMail2 tended to create a “~/.local/share/akonadi_maildir_resource_0” directory for the KMail2 “Local Folders”.

Therefore, this is where the Leap 15 KMail2 places the “Local Folders” content, which is a different behaviour from that with Leap 42.x and, it’s OK – not a bad thing – it’s a decision which has been taken – it’s OK – it doesn’t “break the system” …

Firstly, your configuration is not “messed up” …
Secondly, yes, KMail2 will grey-out the possibility to delete “needed” Folders …

Given that, the “imported” “Local Folders” is empty – in other words, you’ve deleted all the empty Folders which used to contain your imported e-Mails, open the KMail2 Settings menu item “Configure KMail”; select the item “Accounts”; on the page select the tab “Receiving”:

  • You should see two resources named “Local Folders”;
  • Inspect both by means of the option “Modify…”;
  • Select the one which doesn’t use “”~/.local/share/akonadi_maildir_resource_0";
  • Inspect the directory which the “imported” “Local Folders” resource is pointing to – check that, it doesn’t contain anything except, possibly, the “cur/”, “new/” and “tmp/” directories;
  • Remove the “imported” “Local Folders” resource from the KMail2 configuration – if it complains, remove any remaing directories from the directry the KMail2 resource is pointing to;
  • Check that, the related “akonadi_maildir_resource_??
    rc” file has disappeared from “~/.config/” - If removing the resource from the KMail2 configuration didn’t remove the “pointed to” directory, remove it manually.

And no, with the KDE PIM (Kontact), one doesn’t simply, merrily, delete files from the “~/.local/share/” directories – Akonadi will complain bitterly … >:)

I have 1 GB in my “Local Folders” and 3.4 GB in an “Archive Local Folders” area which maps to ~/.local/share/Archiv-local-mail/ – these local folders contain thousands of e-Mails.

  • I’m happy … :slight_smile:

[HR][/HR]Is the KDE PIM Suite a nice, performant (handles large numbers of e-Mails with contents varying from “not much” to “large”), E-Mail, Address Book, Calendar, Tasks, Journal, Notes, News Reader, beast?

  • Yes, my experience is showing that it is …
  • And, it has an awful amount of hooks into a Collabaration Suite – Kolab.

Is it an overkill if, your e-Mail traffic is not that much and, you have no need for an Address Book, Calendar, Tasks, Journal, Notes and a News Reader?

  • Possibly.
  • On the other hand, it does have the ability to import things from other “simpler” applications if your work load increases …

Oh, that’s a relief! That’s what I thought you were telling me earlier. I guess I misunderstood.

Your procedure worked. Thank you so much! KMail seems to be working fine now, and the folders look how I expect them to. That makes me happy.