KMail doesn't see receiving accounts (POP and IMAP)


I have a rather complicated situation. Until 2007, I used OpenSuse, but when I upgraded my Hardware, OpenSuse didn’t work, so I switched to Mandriva, which worked. The last update to Mandriva was however ugly, it didn’t work well, and a tip of another person caused a disaster, i.e. it made my PC unusable.
So I decided to try OpenSuse again, and it worked.
But… not completely. I have a few strange problems.
As I have a vast amount of data on my PC, I can not afford to build everything new, it would take me days. For Mandriva, I had set a symlink from ~/.kde4 to ~/.kde, and KMail etc. worked fine.
Mandriva uses KDE 4.2.2.
However, OpenSuse uses KDE 4.1. Besides some design issues which I will try to figure out, I had a serious problem with KMail: it does see all my sending accounts (however, it shows them all twice), but none of the receiving accounts (I have more than 20) are visible. Thus I cannot receive any E-Mails. I checked kmailrc, it contains all necessary data about these accounts.
In the hope that an update of KDE would solve this problem, I updated to KDE 4.2.9 using the factory thing.
I know from Mandriva that the receiving account info (SMTP) is put in a separate file, but I don’t find any hint as to why KMail doesn’t use the info in kmailrc for the receiving account info any more. This worked absolutely fine under Mandriva.
To enter everything by hand, means a lot of time, and I need to do other things more urgently. Can anyone help?
Thanks in advance!
My system: AMD X2 64-bit, 8 GB RAM, OpenSuse 11.1 86_64.

(BTW, I searched at many places for a hint, but in vain. Hope I didn’t overlook the obvious - in that case my apologies).

DrMartinus wrote:

> To enter everything by hand, means a lot of time, and I need to do
> other things more urgently. Can anyone help?

Did you migrate the accounts with the provided script?

Check this tip from comment #4:

Several config upgrade issues when migrating to…

BTW, you can just create one new account from scratch and compare the
settings with the old ones, looking for any difference.



Thanks for the tip. I did something different, what I had tried yesterday already, but then it was with no success (strange things sometimes happen): I noticed that all the accounts had vanished from the kmailrc file, so I copied them over again today, and this morning it worked.
I’m glad I don’t have to reenter all the accounts again.