Kmail do not send mails


I have a problem with kmail 1.10 (Package 4.0.99-9.1) on OpenSUSE 11.0.
I use 2 identities with different transport methods.
If I try to send a mail kmail it shows a error:
mailtransport “” is invalid. (Translated from german)
The mail stays in the outgoing folder and will not be sent.
On my laptop this error do not appear. If I check the ~/.kde4/share/config/emailidentities and mailtransports there is nothing strange. Its the same as on the Laptop. The names are not exactly the same but semantic the same.
There is no mailtransport named “”, this is the email adress from one of em but not the name.

On the Laptop everything looks the same but it works.
Does anybody know how to solve this?

Thanks a lot

I solved the problem…I don’t know if this goes to the guys at OpenSuSE or kmail…
The problem was either a cache problem or a kde3/kde4.
The mailtransport names in that error window where exactly the names of my kmail kde3 installation.
So I created 2 transports with the kde3 names.
Then kmail seemed to send it but I didn’t configure login details.
Then I renamed the old kde4 ones into the kde3 names and kmail won’t send with the old error message.
But the names of the transports now where the first kde4 names.
So I created anything twice and now it works.
I also did rename the kde3 emailidentities/mailtransports files but with no effect so kmail doesn’t read the kde3 identities/mailtransports.
(Perhaps only on update)
So it is either a cache problem or something strange between a parallel kde3/kde4 Installation.

Greetings from germany