Kmail can send mail to but not receive from new mail server. How to backup for switch to Claws-Mail?

Hello. My wife is running SuSE 13.2 and KMail 4.14.3 with KDE 4.13.3 on her desktop computer. Recently my webmaster switched us to a new mail server because mail from our domain was constantly being blocked by SpamHaus. Spamhaus refused to “white list.”

Following the switch to the new server ( my e-mail (Claws-Mail) continued to work just fine as does e-mail on our cell phones. But her KMail simply refuses to download any mail from

I’ve checked every setting on her KMail as has my webmaster who is a Linux person. Everything is set correctly. The problem seems to be in KMail refusing to “play nice” with the server, so my wife is going to have to switch to Claws-Mail. To do this we have to back-up all of her KMail which I’ll then send to my webmaster who will do some sort of maniupulation of the KMail messages so that they can then be moved into Claws-Mail once that is installed on her computer.

But, where is KDE4 now storing her KMail e-mails?

Previously, with KDE3.5 we could find what we needed in the .kde folder in “home,” for example:


But now as you’re all aware in SuSE 13.2 and KDE4 there is no longer a .kde directory. And when we open the .kde4 folder we don’t see anything that looks like her e-mails.

Switching to a different e-mail client we’re obviously not worried about preserving settings. We just want to be able to back-up the e-mails.

Please, someone, tell me where they’re now hidden? What is the path to her KMail e-mails?

Thanks so much.

Hi, look in the other thread you wrote in:

I did. Please see my response.

I still don’t have any idea where KMail stores the e-mails.


Thank you. :slight_smile:


Hello again.
Can continue here so we don’t neglegt the thread starter of the other thread.

To get back some steps, are you sure you set up KMail to use ssl when trying it with the zoho mail?
I had a quick search and saw a post in the KDE forum explaining that he had to use ssl (encrytion) to send mails using KMail and Zoho. He does not say anything about POP or whatever you wish to use to receive mails but I suppose it more or less implies that he also use KMail to receive mails from Zoho. So then, if it is an option for you to stick with KMail, you could try to set up both the POP (receive) and SMTP accounts using ssl, and skip all the migration to Clawmail?
It is quite easy, I or someone else, can guide you through it if this is an option; it is just a matter of authentication (username [full e-mail address] - password), choose ssl and change ports.


Thanks for the reply. As you understand, the problem is not sending mail. It’s receiving.

The settings for sending are exactly as shown in the link you provided.

The settings for receiving are: Port 995, ssl/tls and authenticate APOP. (Anything else automatically reverts to APOP.)

My wife does NOT want to migrate to Claws-Mail if that can be avoided, but KMail simply will not download mail from the server using what I believe and what my webmaster believes are the correcct settings.

Any other ideas I will be happy to try.

Yes, those are the “receive” settings. But KMail won’t retreive the mail from the server.


Hello again.

I actually managed to configure KMail to retrieve from zoho, created an account to test with.
It was not the setting which were auto detected, so I had some attempts before it went through but it works now.
I can guide you through if you wish?

Here it comes, it’s quite straight forward really, I presume the waiting phase might be the one puzzling your web master, it did to me at least.

KMail set-up:

  Accounts: choose POP

  Account information:

      Account name:             (whatever you wish to call it)
      Incoming mail server:
      Username:                   (full e-mail address)
      Password:                    *******
      Change to  SSL/TLS port: 995
      Authentication = Clear text (When I used the 'Auto Detect' option it gave 'APOP', not 'Clear Text'.

Zoho configuration: (just as in the link)

  Sign in to your mail account on zoho.
    Click on Settings:
      - Email forwarding and POP/IMAP
             - POP Access: choose the 'Enable ...' option you wish, and whether to keep mails on the server or not.

  After configuring the settings Zoho will use about 10 min, or so it seemed (in my experience), to activate the 
  new settings, allowing access from a POP client. 

… authenticate APOP. (Anything else automatically reverts to APOP.)

I’m a bit puzzled about that one, if I manually select ‘Clear text’, or any of the other options (I tried them all), it sticks.

**SOLVED!!! **:):slight_smile:

Thank you so very much, F_Sauce. Manually using “clear text” did allow the e-mail to download from the server.

I know for certain that I tried several times using the “clear text” setting but it did not stick. Maybe that’s because I also tried to do the “auto detect” after selecting “clear text” and it would then reset to APOP. So I figured KMail must be smart and telling me that won’t accept “clear text” – that it only wanted APOP.

When I manually set it to “clear text” and did NOT “auto-detect” then KMail downloading worked with, just as you said it would.

So thank you again so much for all the trouble you went through to find what turned out to be such a simple solution. I just let KMail’s auto-detect feature fool me into thinking it knew better.

My wife is very happy. rotfl!


Well done:)