kmail and unsubscribing folders not working

Can anyone tell me why when I unsubscribe a folder of an account in kmail it doesn’t take. That is, the folder still shows, I close and reopen the app the folder still shows, I open “manage local subscriptions” and all folder are still checked instead of the ones I unchecked remaining as unchecked.

I thought it might be because I had cached all folders locally but I can’t believe the app isn’t smart enough to deal with that when unsubscribing.

It shows it’s version as 5.3.0.

Yes, I had this problem, too. It does work (again) in tumbleweed with kmail 5.5.2. Either wait for 42.3, go Tumbleweed, or try to find fixed or updated packages for 42.2, though I do not recommend using any KDE version other than the one shipped with the OS version. It has never worked for me.

There is a manual way to hide the folders in kmail. If you do not want to risk upgrades but really want those folders hidden, try this:

If you know some SQL, you can directly access akonadi’s database via mysql client. Otherwise install akonadiconsole, start it, go to tab DB Browser, select collectiontable from the dropdown, hit the refresh button. You will see database rows. Click the parentId column header to sort by it. Now the names are grouped and you should be able to match names to what you see in kmail. Scroll to the right, there is a column named enabled which has mostly values of 1 (true) for the rows. Double click a cell and you can set it to 0 (false). Which makes the item disappear in the folder list (possibly only after a restart of akonadi - can’t remember).

Great answer, thank you so much!

Definitely not good to edit a database to solve issues like this. Good chance that other things will break.