KMail and Asian fonts

Since upgrading to OS 12.2 I have switched my email client from Thunderbird to KMail.
Everything works pretty well except for one nagging issue I have.

I am a native English speaker using an English OS who lives and works in Japan. As such, a lot of emails I receive are in Japanese.

In KMail the font used to display Japanese characters is downright ugly. It looks to be defaulting to IPAGothic.
There does not appear to be any option in kmail to specify a font I’d like to use for received emails (it’s there for English but not other languages).
There is an option to select the desired font in composer.

It could be that KMail is defaulting to the system default for Japanese (I have this installed as a secondary language) - but I can’'t find any option to locate or alter that.

Any ideas.

and god these forums suck at the moment . . . - this is my fourth attempt at trying to post this message without losing everything.

perhaps the solution may lie in editing the .fonts.conf file . . . but where to start?

I guess that this isn’t of much help, but I do not think that Kmail itself has any font configuration as it is an integrated part of KDE. I would search for font configuration options in KDE itself in the hope that Kmail will follow.

yes, you are spot on.

I think I have it.

adding the following to /home/user/.fonts.conf seems to have done the trick

            <family>sazanami gothic</family>

I added arial in there as well as I prefer it to whatever the fallback font in Opensue is (maybe droidsans or something)

This also seems to fix up the ugly Japanese font in Chrome / Chromium - although in the next chrome / chromium milestone there is supposed to be an extension that will take care of this on a charset basis (similar to thunderbird / firefox)

Nice that I could be of help even when I only guessed a bit around :wink:

And thank you for reporting back. Can be of help to others.