Kmail akonadi and mysql errors.

Not sure if this is correct place to ask this?

Kmail 1.13.2

Problem on startup, error is from nepomuk, data storage. "cannot
find Redland backend, nepomuk is disabled until fixed. Also see the
following error from the akonadi console:

100503 10:00:15 [Note] Plugin ‘ndbcluster’ is disabled.
100503 10:00:15 InnoDB: Started; log sequence number 0 31413862
100503 10:00:15 [Warning] Can’t open and lock time zone table: Table
‘mysql.time_zone_leap_second’ doesn’t exist trying to live without
them
100503 10:00:15 [ERROR] Can’t open and lock privilege tables: Table
‘mysql.servers’ doesn’t exist
100503 10:00:15 [ERROR] Cannot open mysql.db
100503 10:00:15 [ERROR] Cannot open mysql.user
100503 10:00:15 [ERROR] Cannot open mysql.event
100503 10:00:15 [ERROR] Event Scheduler: An error occurred when
initializing system tables.
100503 10:00:15 [Note] /usr/sbin/mysqld: ready for connections.
Version: ‘5.1.36-log’ socket:
‘/home/finemanruss/.local/share/akonadi/db_misc/mysql.socket’ port:
0 SUSE MySQL RPM
100503 14:02:55 [Warning] Aborted connection 14 to db: ‘akonadi’
user: ‘finemanruss’ host: ‘’ (Got an error reading communication
packets)

rpm’s providing ndbcluster is installed, also two redland scripts
are installed in /usr/bin.(redland-config and redland-db-upgrade).
YaST says everything is installed.

I tried going thru the trouble shooting info on KDE website but some
of the commands they say to use are not on the 11.2 system.

Also the last line of above errors shows user id, that user ID needs
a password, where do you put it? Also does it need to be a part of
the mysql group?

Any help getting this working will be greatly appreciated. I have
new letter to publish and need to ate distribution lists from my
personal contacts groups.

Thanks


Russ
| openSUSE 11.2 (2.6.31.12-18-desktop) x86_64 | KDE 4.4.2 (using KDE
4.4.2 | Intel Core 2 Dual E7200 | 4 GB RAM | GeForce 8400 GS | 320GB
Disc (2) |

Could it be you don’t have mysqld started? Enable the daemon through Yast-System-Runlevels

Knurpht wrote:

>
> Could it be you don’t have mysqld started? Enable the daemon
> through Yast-System-Runlevels
>
>
Thanks for your input. Mysqld is running.

3903 ? 00:00:00 akonadi_birthda
3905 ? 00:00:00 akonadi_contact
3907 ? 00:00:00 akonadi_ical_re
3909 ? 00:00:00 akonadi_maildir
3911 ? 00:00:00 akonadi_maildis
3913 ? 00:00:00 akonadi_nepomuk

3866 ? 00:00:00 mysqld

3969 ? 00:00:00 nepomukservices
3970 ? 00:00:00 nepomukserviceakonadi is starting,
but PS says they are started.
3971 ? 00:00:00 nepomukservices
3972 ? 00:00:00 nepomukservices
3973 ? 00:00:00 nepomukservices

Yesterday when I sent the original message, nepomuk was getting
error and not starting. I finally found a thread on the KDE formum
that said to add redland directory to
~/.kde4/share/apps/nepomuk/repository/main/data along with the
virtuosobackend directory. The redland folder is still empty but
the nepomuk contact passing feature is now working and I do not get
the error on startup. In fact I don’t see the little window saying
akonadi is starting. PS says they are started (see above).

Only error I see now is in the mysql.err log in:
~/.local/share/akonadi/db_data

100504 8:36:34 [Note] Plugin ‘ndbcluster’ is disabled.
100504 8:36:34 InnoDB: Started; log sequence number 0 32094004
100504 8:36:34 [Warning] Can’t open and lock time zone table:
Table ‘mysql.time_zone_leap_second’ doesn’t exist trying to live
without them
100504 8:36:34 [ERROR] Can’t open and lock privilege tables: Table
‘mysql.servers’ doesn’t exist
100504 8:36:34 [ERROR] Cannot open mysql.db
100504 8:36:34 [ERROR] Cannot open mysql.user
100504 8:36:34 [ERROR] Cannot open mysql.event
100504 8:36:34 [ERROR] Event Scheduler: An error occurred when
initializing system tables.
100504 8:36:34 [Note] /usr/sbin/mysqld: ready for connections.
Version: ‘5.1.36-log’ socket:
‘/home/finemanruss/.local/share/akonadi/db_misc/mysql.socket’
port: 0 SUSE MySQL RPM
100504 8:39:30 [Warning] Aborted connection 12 to db: ‘akonadi’
user: ‘finemanruss’ host: ‘’ (Got an error reading communication
packets)

I think the issue could be that mysql requires a password for the
user ID mentioned in last line. I tried changing
~/.config/akonadi/akonadiserverrc and added ID and password, but
something overroad it and created a new file with:

[QMYSQL]
Name=akonadi
Host=
User=
Password=
Options=“UNIX_SOCKET=/home/finemanruss/
.local/share/akonadi/db_misc/mysql.socket”
ServerPath=/usr/sbin/mysqld
StartServer=true

When I look at MY sql with phpMyAdmin I do not see a database
called akonadi, so I assume it is local directory. Not sure if I
should see it?

I’ll keep plugging away at it. Any suggestions, or maybe its now
working Ok, but why mysql error messages?


Russ
| openSUSE 11.2 (2.6.31.12-18-desktop) x86_64 | KDE 4.4.2 release
241 | Intel Core 2 Dual E7200 | 4 GB RAM | GeForce 8400 GS | 320GB
Disc (2) |