KMail access to Gmail account stop working

I’ve this situation :

  1. Desktop with Leap 15.1 installed on July where I cannot read Gmail account with Kmail
  2. Laptop with Leap 15.1 installed at the end on May where until yesterday I was able to read Gmail account with kmail
    Gmail account is the same and I can access to it with same PC (Desktop & Laptop) if I boot it with Leap 15.0.
    Yesteday I updated my Laptop and now I get this error when Kmail try to access the Gmail account :
    “Impossibile leggere la password: l’utente ha negato l’accesso al portafogli” -> Not possible to read the password : user denies access to wallet
    It’s difficult to know what happened because the error seem relateted to wallet (kdewallet) but with Kmail & Gmail account nothing is stored to kdewallet.
    This is the Kmail account configuration (working on Leap 15.0 & on Leap 15.1 until yesterday):
    Server Imap :
    User Name :
    Password : nothing -> It was stored with Gmail/Akonadi authentication I suppose on Gmail servers
    Cipher : SSL/TLS
    Port : 993
    Authentication : Gmail

If I delete the Kmail (Gmail) account and I try to recreate it I get directly the same message error -> Not possible to read the password : user denies access to wallet
It seems there is something wrong with Akonadi (I remember that with Gmail should start Akonadi authentication process where I type gmail account, I type gmail password and If everything is OK I can access to Gmail. Gmail password is not saved on PC wallet).

Maybe the issue is not strictly related to Kmail/Akonadi but is on my Gmail account (maybe Google changed something in authentication process) …

Please take a look at this KDE Forum post: <;.

I had the same problem, it’s due to the fact that kmail is considered a less secure app. Solved it by doing this:

  • Enable 2 factor authentication in google settings
  • Generate an app password as stated here: Sign in with app passwords - Gmail Help
  • In Kmail > Settings > Account > Delivery > Double click on Google Mail > Copy the generated app password in password field

Please note that, the KDE Forum answer seems to need KWallet to store the App password generated by the Alphabet folks …

There’s also this post: <;.

The KMail documentation is here: <; – <;.
[HR][/HR]For those who are wondering, Alphabet owns Google …

Thanks dcurtisfra,
you pointed me to find the correct solution.

The issue was on google side, THEY decided to disable less secure app (or decided that Akonadi / Kmail is not a secure app) . In fact also on Leap 15.0, from this morning, no longer work the access to Gmail.

So this is what I did.
On GMail side (I translate from Italian To English maybe the terms used are not exactly what proposed by Google in native English) :

  • in my account I disabled ‘access to less secure app’
  • I enabled ‘verification in 2 steps’
  • I created a password for app -> as ‘app name’ I chosen Posta (Post) and I typed kmail, as ‘device’ I choosen Others. GMail generated a password of 16 characters

On Kmail side :

  • I added a new receiving ‘custom account’, with IMAP
  • Server Imap :, User Name :, Password : app password generated by Gmail (that will be stored in kwallet as it was in past edition of Opensuse)
  • Cipher : SSL/TLS, Port : 993, Authentication : PLAIN (NOT Gmail as it was in Leap 15.0 with Akonadi App authentication)

Hope that helps someone else.

Hi MaxRiservo,

you wrote

Cipher : SSL/TLS, Port : 993, Authentication : PLAIN (NOT Gmail as it was in Leap 15.0 with Akonadi App authentication)

I am using Leap 15.0 and in my Kmail I am not able to select the authentication method. As soon as I am entering the password field is grayed out and also the authentication method field (I cannot change it from Gmail to Plain.).

Do I understand correctly that I need to upgrade to Leap 15.1 first before I am able to use Gmail again in Kmail?

I don’t know if it mandatory to update to LEap 15.1.
Until few days ago with Leap 15.0 KMail-Gmail worked fine but I stopped to use Leap 15.0 +/- 2 months ago in favor of Leap 15.1 where Kmail-Gmail works on 1 PC (in the same way worked on Leap 15.0) and doesn’t not work on second PC.
Only when stop working also on first PC I decided to investigate & try to solve the issue.
I found that the problem in my case was on GMail side : I disabled ‘less secure app’ (it was mandatory for permitting to Kmail-Akonadi to access Gmail account- now I believe is no more useful) and I enabled ‘verification in 2 steps’. Also authentication method in Kmail need to be changed from Gmail to Plain.
So if in Leap 15.0 is not possible to change Kmail authentication from Gmail to Plain and want to access Gmail account with Kmail, I believe you have no choise : you have to update your distro to LEap 15.1
Before upgrading your distro I suggest to check your Gmail account and verify if nothing is missing / requested by Google (mobile phone, email for backup, verification in 2 steps and maybe other you can find under security).

It seems that, Alphabet / Google are beginning to use “two step verification” – which is what the European Banking System is also currently doing for their customers’ Internet access to their Bank Accounts …

To avoid the “two step verification” process for e-Mail, there is, AFAICS, only one method: use the e-Mail system provided by your DSL supplier …

  • “Two step verification” is not needed because, you’re accessing the e-Mail Service via the VPN of the DSL/Telephony supplier …
  • The only exception is, when you’re travelling and, accessing your e-Mail service via the Internet – then, the only security is your account identity and, your password, plus, the TLS between the e-Mail Client and the e-Mail service of your DSL/Telephony supplier …

On the other hand, within the Google world, the only security they have, is the Android OS «a Linux» and, the connection between the mobile Telephone and Alphabet (Google) – via a PSTN (Public switched telephone network) – which, given the security built into the Wireless Interface and, the inherent security of the PSTN terrestrial networks, is secure, up to the point where the given PSTN accesses the Internet to access Google’s Gmail service …

I’ve obviously missed something, but why do you (and a couple of others I’ve seen here) continually call Google, Alphabet?

Google is still Google but the parent company is now called Alphabet

In addition to what gogalthorp wrote, the same reason why I refer to the “Redmond folks” rather than “Microsoft employees” …

  • Regarding Google, one could reflect on the reasons why the “Google Summer of Code” (GSOC) occurs …

Guess I was completely out of the loop somehow. Thanks for the update.

This has now been fixed:<;

Reddit URL correction:<;