KMail 2 in KDE 4.8.0 on openSUSE 12.1

I upgraded my KDE install to 4.8.0 and now when I receive email from a prior contact who uses Apple Mail to send from an iPad2, what I get is the header info “Apple-Mail, 64Bit Encoding UTF-8”, etc. and all I see is the Mime Code not the actual email that I can read.

This did not happen until the switch to 4.8.0

Is this a known issue and is there a way to correct it?

I tried switching Encoding manually with no effect. I choose to receive mail in text only and show the message source so I can manually select to display the HTML version if needed. On these emails the message source only shows a line that says text email, no HTML option.

Did you get the whole mails with KDE 4.7? Did you ask him to send another
mail from his iPad? Maybe KMail isn’t the problem in this case.

Did you look at the plain mail? (Press “v”, when the mail is selected)

Yes I never had a problem receiving mails when using KDE 4.7 series releases. I tried viewing in text and it is all mime code, here is the beginning snipet of of the text window that I receive.

Content-Transfer-Encoding: base64
Content-Type: text/plain; charset=“utf-8”


It also appears that HTML messages in general are hit or miss, arriving either as just pure text with no ability to utilize the links embedded. I just received one from a standard source that always used to arrive as an HTML that I could click on the link to perform a customer survey. Now since 4.8, it arrives as pure text with no links available. Not good.

With a little more exposure, it appears any email that is HTML basically shows up as garbage and unreadable. Examples are from gmail, yahoo and live mail. Any attachments such as pictures are not retrievable. Never had this problem prior to 4.8

Does this thread help at all?

weighty foe wrote:

> Does this thread help at all?

Not really, but thanks. I disabled the pipe through spamassassing and it
does not make a difference. I just uninstalled it now and deleted the
filters to see if it changes anything.

I somehow missed seeing this thread when I searched for the topic prior to posting this thread. I have now disabled my SpamAssassin and ClamAV filters, then closed and restarted Kontact. I will see if it has any improvement over the next couple of days. Thanks for the pointer. :slight_smile: Hopefully this will do the trick for me.

Just an FYI update. I disabled both the SpamAssassin and ClavAV Filters within KMail and that does seem to have corrected it. I’ve been able to view and read every email I’ve received the past three days.

Thanks for pointing that thread out. :slight_smile: Happy Camper again here.

You are very welcome, glad it’s sorted :slight_smile: