Kleines, ziemlich spezifisches Problemchen

Hallo, eigentlich habe ich nur ein winziges, dummes Problem: ich habe unter leap 42.1/KDE meinen account umbenannt. Es hat soweit auch alles wunderbar geklappt, nur hatte ich direkt auf dem Desktop einige icons von häufig gebrauchten Programmen abgelegt. Der Ordner ist durchaus noch im neuen home/user-Verzeichnis vorhanden, allerdings weist wohl irgend ein Pfad in irgendeiner config noch auf das alte userverzeichnis, jedenfalls erscheint jetzt immer mitten auf dem Desktop die Meldung, dass dieser Pfad nicht existiert.

Das ist eigentlich kein Problem, nur unschön. Ich habe nun schon alle möglichen config-Dateien durchtstöbert und nichts gefunden. Kann mir jemand auf die Sprünge helfen, in welcher das hinterlegt ist? Das ist doch wohl einfach zu ändern, wenn man weiss, wo?

Google hilft mir da leider nicht viel weiter.

Evtl. Systemeinstellungen->Anwendungen->Orte, wenn ich dein Problem richtig verstehe, bzw. die entsprechende Config-Datei ist ~/.config/user-dirs.dirs. Speziell der “Pfad zur Arbeitsfläche” (XDG_DESKTOP_DIR).

Wenns das nicht ist, wäre vielleicht ein Bildschirmfoto hilfreich…
(hochladen kann man hier keine Bilder, du musst dafür http://susepaste.org oder ähnliche Dienste verwenden)

Danke, das ging ja mal wieder schnell und kommt der Sache näher:

bei Systemeinstellungen->Anwendungen->Orte stehen die richtigen Pfade. Das Problem scheint in der user-dirs.dirs zu liegen, dort wird eine Umgebungsvariable verwendet ($HOME), und die scheint falsch zu sein.

Jetzt ist halt die Frage, wo die nun wieder deffiniert wird…
Den absoluten Pfad anzugeben habe ich schon versucht, das hilft nicht weiter.

Übrigens habe ich jetzt noch festgestellt, dass bel dolphin links unter “Orte” 2x ein “persönlicher Ordner” aufgelistet ist, von denen einer ebenfalls noch auf das alte home/user-Verzeichnis zeigt.

Die wird nirgends definiert, sondern beim Einloggen auf das Homeverzeichnis des Benutzers gesetzt.

Das Homeverzeichnis wird in /etc/passwd festgelegt, also schau dort mal obs korrekt ist.

Ich glaube, jetzt haben wirs: es gibt “passw”, das enthält den richtigen Pfad, und “passwd-”, da steht der falsche.

Und ich habe wohl einmal mehr Verwirrung angerichtet: um mich als su anzumelden, funktioniert nur das alte Passwort. Unter dem geänderten PW für den umbenannten user geht das nicht.

Da schließt sich doch gleich die nächste dumme frage an: wie kriege ich das wieder los? Ich habe wohl beim ändern des Usernamens und PW keine Adminrechte vergeben, so dass das noch über das alte PW erfolgen muss. Aber das Konto gibts ja nicht mehr, also komme ich da nicht ran.

Kann ich mir jetzt einfach einen root einrichten für die Administartion? Wäre mit eigentlich sowieso lieber. Ich trau mich jetzt nicht mehr einfach so rumzuspielen, mal sieht ja mal wieder wohin das führt…

Nein, das ist normal.

passwd~ ist eine Sicherheitskopie.

Wenn passwd das richtige Verzeichnis enthält, sollte alles in Ordnung sein.

Und ich habe wohl einmal mehr Verwirrung angerichtet: um mich als su anzumelden, funktioniert nur das alte Passwort. Unter dem geänderten PW für den umbenannten user geht das nicht.

Auch das ist normal.

su fragt nach dem root Password.
Bei einer neuen Installation wird per default das Passwort des Benutzers auch für root gesetzt.
Wenn du aber das Benutzerpasswort änderst, wird das Passwort für root logischerweise nicht mitgeändert, weil root eben ein unabhängiger Benutzeraccount ist.

Da schließt sich doch gleich die nächste dumme frage an: wie kriege ich das wieder los? Ich habe wohl beim ändern des Usernamens und PW keine Adminrechte vergeben, so dass das noch über das alte PW erfolgen muss. Aber das Konto gibts ja nicht mehr, also komme ich da nicht ran.

Sowas wie “Adminrechte” für normale Benutzer gibt es nicht…

Und an das root Konto kommst du schon ran, da es überhaupt nichts mit dem Benutzerkonto zu tun hat, weder dem jetzigen noch dem vorigen.

Kann ich mir jetzt einfach einen root einrichten für die Administartion? Wäre mit eigentlich sowieso lieber. Ich trau mich jetzt nicht mehr einfach so rumzuspielen, mal sieht ja mal wieder wohin das führt…

root ist eingerichtet, und hat eben immer noch das gleiche Passwort wie vorher.
Um das zu ändern, führe “passwd” als root aus (also z.B. nach “su”), bzw. sollte auch in YaST möglich sein.

Zu deinem ursprünglichen Problem:
Wieso glaubst du eigentlich das $HOME falsch gesetzt ist?
Was sagt denn:

echo $HOME

(als Benutzer in der grafischen Sitzung ausgeführt)

echo $HOME zeigt den richtigen Pfad.

Ich habe passw- durche eine Kopie von passw ersetzt, und in passw.YaST2save den dort ebenfalls falsche Eintrag geändert.

Ich habe den Ordner “Desktop” so freigegeben, wie es nur geht.

Es hilft alles nix.

Ich lasse das für heute mal sacken und mach Feierabend.

Danke übrigens für die Erklärungen zum root, es dämmert mir langsam wieder.

Gut.
Hab ich eigentlich fast vermutet, andererseits hättest du wahrscheinlich sowieso größere Probleme…

Ich habe passw- durche eine Kopie von passw ersetzt, und in passw.YaST2save den dort ebenfalls falsche Eintrag geändert.

Wär nicht notwendig gewesen.
Verwendet wird nur passwd.

Ich habe den Ordner “Desktop” so freigegeben, wie es nur geht.

Versteh ich jetzt nicht ganz.

Aber wie gesagt, poste vielleicht mal ein Bildschirmfoto, vielleicht wird das Problem dann klarer.

Ansonsten mach mal ein grep über den .config Ordner um hoffentlich die Ursache zu finden:

grep -R *falsches_home_verzeichnis* ~/.config

Dort befinden sich alle Plasma5 config Dateien…

Hmmm… ich habe grep wie beschrieben durchgeführt, es liefert jede Menge Zeug, das auf den nicht mehr existierende user verweist.

Ein Bildschirmfoto nützt die nicht wirklich viel, da steht einfach mitten auf den Desktop “Die Datei oder der Ordner /home/alter user/Desktop existiert nicht”. Das ist kein Fesnter oder requester, das steht einfach mitten auf dem Hintergundbild.

Gerdade habe ich mal probiert ein neues Programm auf den Desktop zu ziehen, es geht nicht, “Zugriff verweigert”

Irgendwas ist hier ernsthaft verrutscht…

Tja, je nachdem was für Zeugs das genau ist, kann es notwendig sein da noch mehr anzupassen.

Wenn du willst kannst du die Ausgabe ja mal posten (http://susepaste.org oder ähnliches verwenden wenns zu lang ist), dann werf ich einen Blick drauf.

Ein Bildschirmfoto nützt die nicht wirklich viel, da steht einfach mitten auf den Desktop “Die Datei oder der Ordner /home/alter user/Desktop existiert nicht”. Das ist kein Fesnter oder requester, das steht einfach mitten auf dem Hintergundbild.

Ein Bildschirmfoto könnte helfen Missverständnissen vorzubeugen… :wink:

Hört sich aber immer noch danach an dass die Meldung von der “Ordneransicht” kommt.
Schon mal probiert auf den Desktop rechtszuklicken (bzw. auf das Toolbox-Symbol links oben, früher bekannt als “Cashew”, links-klicken) und “Ordner Einstellungen” auszuwählen?
In den Einstellungen kannst du festlegen, welcher Ordner angezeigt wird.
Das Default (“Arbeitsflächenordner”) nimmt den Ordner der in den Systemeinstellungen gesetzt ist, man kann aber explizit einen bestimmten Ordner setzen.

Die Plasma-Konfiguration ist übrigens in ~/.config/plasma-org.kde.plasma.desktop-appletsrc.

Gerdade habe ich mal probiert ein neues Programm auf den Desktop zu ziehen, es geht nicht, “Zugriff verweigert”

Klar, wenn der falsche Ordner als “Arbeitsfläche” benutzt wird.

OK, OK, ich war mal wieder zu blöd…

Bei den Arbeitsflächen-Einstellungen von “Ordneransicht” zu “Arbeitsfläche” umgeschaltet, und ich kann jetzt immerhin wieder Icons auf def dem Desktop ablegen.

Die Symbole aus dem existierenden Desktop-Ordner werden zwar nicht angezeigt, und neu erstellte tauchen nicht darin auf, aber immerhin funktionierts. Und es sieht anders aus als vorher, die Icons haben einen intransparenten Hintergrund und sind nicht verschiebbar (vorher konnte ich sie sperren und entsperren).

Ich glaube fast, ich hole mir meien letzten snapshot zurück und fang nochmal von vorne an, denn eigentlich verwende ich linux ja, weil ich eben nicht basteln will…

Nein, das war falsch.
Damit hast du praktisch die Anzeige von Dateien/Icons auf der Arbeitsfläche abgeschaltet.
Neue kannst du anlegen, das sind aber Icon-Widgets und haben mit dem Desktop Ordner überhaupt nichts zu tun.

Schalt das wieder zurück auf “Ordneransicht”, da du ja scheinbar so einen “klassischen” Desktop haben willst.

Und dann gehen noch mal in die Einstellungen, klicke auf “Ort” und ändere dort das Verzeichnis das angezeigt wird entsprechend (falls noch notwendig), wie ich geschrieben habe.

http://wstaw.org/m/2016/06/10/desktop.png

Gut, danke. Ich hab mich jetzt wieder etwas beruhigt.

Die Einstellungen habe ich wie beschrieben geändert, die Fehlermeldung ist jetzt weg, aber Icons sind trotzdem keine da. Ich kann neue Verknüpfungen angegen, die aber dann ebenfalls unsichtbar bleiben. Würde es helfen, einfach einen neuen Desktop-Ordner anzulegen?

Hier erstmal die Ausgabe von greb, beim OpenOffice-Teil musste ich aber kürzen, das wäre sonst zu lang geworden (mehr als 18.000 zeichen):

[/home/dau/.config/vlc/vlc-qt-interface.conf:filedialog-path=/home/manfred
/home/dau/.config/vlc/vlc-qt-interface.conf:list=file:///home/dau/Musik/Embyo%20-%20Ibn%20Battuta%20-%201994/Embyo%20-%20Ibn%20Battuta%20-%2001%20-%20Code%207.mp3, file:///home/manfred/Musik/Reverend_Shine/01.%20St%C3%BCck%201.ogg, file:///home/manfred/Musik/Real%20Ax%20Band%20-%20Mobe%20your%20Ass%20in%20Time%20-%201977/Real%20Ax%20Band%20-%20Mobe%20your%20Ass%20in%20Time%20-%2008%20-%20Madurszth.mp3, file:///home/manfred/Musik/Real%20Ax%20Band%20-%20Mobe%20your%20Ass%20in%20Time%20-%201977/Real%20Ax%20Band%20-%20Mobe%20your%20Ass%20in%20Time%20-%2006%20-%20I%23m%20checking%20my%20problems%20out.mp3, file:///home/manfred/Musik/Real%20Ax%20Band%20-%20Mobe%20your%20Ass%20in%20Time%20-%201977/playlist.m3u, file:///home/manfred/Musik/Magma%20-%20Live%20-%20/Magma%20-%20Live%20-%2005%20-%20Mekanik%20Zain.mp3, file:///home/manfred/Musik/Magma%20-%20Live%20-%20/Magma%20-%20Live%20-%2004%20-%20Hhai.mp3, file:///home/manfred/Musik/Magma%20-%20Live%20-%20/Magma%20-%20Live%20-%2003%20-%20Lihns.mp3, file:///home/manfred/Musik/Magma%20-%20Live%20-%20/Magma%20-%20Live%20-%2002%20-%20Kobah.mp3, file:///home/manfred/Musik/Magma%20-%20Live%20-%20/Magma%20-%20Live%20-%2001%20-%20Kuhntark%2C%20Pts.%201-2.mp3, file:///home/manfred/Musik/Magma%20-%20Live%20-%20/playlist.m3u, file:///home/manfred/Musik/Rainald%20Grebe%20singt%20Ich%20bin%20der%20Pr%C3%A4sident.mp4
/home/dau/.config/kdeglobals:dbfile=/home/manfred/.mozilla/firefox/ygw1vr8x.default/places.sqlite
/home/dau/.config/akonadi/akonadiconnectionrc:UnixPath=/tmp/akonadi-manfred.JbsChy/akonadiserver.socket
/home/dau/.config/akonadi/akonadiserverrc:Options="UNIX_SOCKET=/tmp/akonadi-manfred.JbsChy/mysql.socket"
/home/dau/.config/teamviewer/client.conf:[strng] Meeting_UserName = "manfred-tuxedo"
/home/dau/.config/konversationrc:Ident=manfred
/home/dau/.config/konversationrc:Nicknames=manfred,manfred_,manfred__
/home/dau/.config/konversationrc:Realname=manfred
Übereinstimmungen in Binärdatei /home/dau/.config/q4wine/db/generic.dat.
/home/dau/.config/q4wine/default.conf:prefixDefaultPath=/home/manfred/.local/share/wineprefixes
/home/dau/.config/vivaldi/Default/Extension Rules/LOG.old:2016/05/30-20:45:41.669 4266 Reusing MANIFEST /home/manfred/.config/vivaldi/Default/Extension Rules/MANIFEST-000001
/home/dau/.config/vivaldi/Default/Extension Rules/LOG.old:2016/05/30-20:45:41.670 4266 Reusing old log /home/manfred/.config/vivaldi/Default/Extension Rules/000003.log 
/home/dau/.config/vivaldi/Default/Session Storage/LOG.old:2016/05/30-20:45:42.596 4264 Reusing MANIFEST /home/manfred/.config/vivaldi/Default/Session Storage/MANIFEST-000001
/home/dau/.config/vivaldi/Default/Session Storage/LOG.old:2016/05/30-20:45:42.597 4264 Reusing old log /home/manfred/.config/vivaldi/Default/Session Storage/000008.log 
/home/dau/.config/vivaldi/Default/Local App Settings/mpognobbkildjkofajifpdfhcoklimli/LOG.old:2016/05/30-20:45:41.736 4266 Reusing MANIFEST /home/manfred/.config/vivaldi/Default/Local App Settings/mpognobbkildjkofajifpdfhcoklimli/MANIFEST-000001
/home/dau/.config/vivaldi/Default/Local App Settings/mpognobbkildjkofajifpdfhcoklimli/LOG.old:2016/05/30-20:45:41.736 4266 Reusing old log /home/manfred/.config/vivaldi/Default/Local App Settings/mpognobbkildjkofajifpdfhcoklimli/000003.log 
/home/dau/.config/vivaldi/Default/Thumbnails/LOG.old:2016/05/30-20:45:41.620 4309 Reusing MANIFEST /home/manfred/.config/vivaldi/Default/Thumbnails/MANIFEST-000001
/home/dau/.config/vivaldi/Default/Thumbnails/LOG.old:2016/05/30-20:45:41.621 4309 Reusing old log /home/manfred/.config/vivaldi/Default/Thumbnails/000003.log 
/home/dau/.config/vivaldi/Default/Extension State/LOG.old:2016/05/30-20:45:42.624 4266 Reusing MANIFEST /home/manfred/.config/vivaldi/Default/Extension State/MANIFEST-000001
/home/dau/.config/vivaldi/Default/Extension State/LOG.old:2016/05/30-20:45:42.625 4266 Reusing old log /home/manfred/.config/vivaldi/Default/Extension State/000003.log                                                                                             
/home/dau/.config/vivaldi/Default/data_reduction_proxy_leveldb/LOG.old:2016/05/30-20:45:41.552 4309 Reusing MANIFEST /home/manfred/.config/vivaldi/Default/data_reduction_proxy_leveldb/MANIFEST-000001                                                             
/home/dau/.config/vivaldi/Default/data_reduction_proxy_leveldb/LOG.old:2016/05/30-20:45:41.552 4309 Reusing old log /home/manfred/.config/vivaldi/Default/data_reduction_proxy_leveldb/000003.log 
/home/dau/.config/vivaldi/Default/Storage/ext/mpognobbkildjkofajifpdfhcoklimli/def/IndexedDB/chrome-extension_mpognobbkildjkofajifpdfhcoklimli_0.indexeddb.leveldb/LOG.old:2016/05/30-20:45:42.194 4272 Reusing MANIFEST /home/manfred/.config/vivaldi/Default/Storage/ext/mpognobbkildjkofajifpdfhcoklimli/def/IndexedDB/chrome-extension_mpognobbkildjkofajifpdfhcoklimli_0.indexeddb.leveldb/MANIFEST-000001
/home/dau/.config/vivaldi/Default/Storage/ext/mpognobbkildjkofajifpdfhcoklimli/def/IndexedDB/chrome-extension_mpognobbkildjkofajifpdfhcoklimli_0.indexeddb.leveldb/LOG.old:2016/05/30-20:45:42.194 4272 Reusing old log /home/manfred/.config/vivaldi/Default/Storage/ext/mpognobbkildjkofajifpdfhcoklimli/def/IndexedDB/chrome-extension_mpognobbkildjkofajifpdfhcoklimli_0.indexeddb.leveldb/000003.log 
/home/dau/.config/libreoffice/4-suse/user/registrymodifications.xcu:<item oor:path="/org.openoffice.Office.Histories/Histories/org.openoffice.Office.Histories:HistoryInfo'PickList']/OrderList"><node oor:name="0" oor:op="replace"><prop oor:name="HistoryItemRef" oor:op="fuse"><value>file:///run/media/manfred/FREECOM%20HDD/Stammbaum/%C3%BCbersicht.ods</value></prop></node></item>
/home/dau/.config/libreoffice/4-suse/user/registrymodifications.xcu:<item oor:path="/org.openoffice.Office.Histories/Histories/org.openoffice.Office.Histories:HistoryInfo'PickList']/ItemList"><node oor:name="file:///run/media/manfred/FREECOM%20HDD/Stammbaum/%C3%BCbersicht.ods" oor:op="replace"><prop oor:name="Title" oor:op="fuse"><value>übersicht</value></prop><prop oor:name="Filter" oor:op="fuse"><value>calc8</value></prop><prop oor:name="Password" oor:op="fuse"><value></value></prop><prop oor:name="Thumbnail" oor:op="fuse"><value>iVBORw0KGgoAAAANSUhEUgAAAQAAAADBCAIAAACv0/mUAACcR0lEQVR4nO3dB7heRbU38H0iV7HLBdtFSsSO4pVmAOm9K72HLr33jnQIEEJCDYEEQgsllEDoGAi9F2nSQXp.................................................hier habe ich ca 10.000 Zeichen rausgekürzt.........................................cDCmSnrq3Qqr5cy6MmwelUDpWpFEaXLWYDiSRrKkxQrGz43Kyw9TaPNYu+3UTWUeYN0LZMAZcSzapzNmner1vrMLPktJJWbLFoqDJxMyPlg1/8DkJ9mSnwgWZYAAAAASUVORK5CYII=</value></prop></node></item>
/home/dau/.config/dragonplayerrc:[file:///home/manfred/Musik/Ministry_-_NWO_Subtitulado_en_espa_ol.mp4]
/home/dau/.config/dragonplayerrc:[file:///home/manfred/Musik/Rainald Grebe singt Ich bin der Präsident.mp4]

Sorry, wenn ich mich so blöd anstelle, ich in erst frisch wieder zu suse und kde zurückgekehrt und irgendwie hatte ich solche Probleme bei den diversen ubuntu/debian-Varianten nicht. Dafür halt einen Haufen andere, aber ich muss vieles erst wieder lernen, vor allem vorsichtiger zu sein…

Und auf was genau ist die Einstellung jetzt?

Hört sich ja fast nach “Dateien anzeigen, die mit der aktuellen Aktivität verknüpft sind” an. Das ist aber höchstwahrscheinlich nicht was du willst da eben nur Dateien angezeigt werden die du vorher explizit der aktuellen Aktivität zugewiesen hast (z.B. via “Aktivitäten” im rechts-klick Menü in Dolphin)

Die anderen sollten definitiv den entsprechenden Ordner anzeigen.
Um sicherzugehen, wähle halt einfach “Ordner angeben” und trag den Pfad zu deinem neuen Desktop-Ordner ein, bzw. klick auf das Ordner-Icon und wähle ihn im Verzeichnisdialog.

Würde es helfen, einfach einen neuen Desktop-Ordner anzulegen?

Vermutlich nicht.
Prinzipiell kannst du aber jeden beliebigen Ordner als Desktop-Ordner verwenden.

Hier erstmal die Ausgabe von greb, beim OpenOffice-Teil musste ich aber kürzen, das wäre sonst zu lang geworden (mehr als 18.000 zeichen):

Das meiste sind nur zuletzt gewählte Dateien und Ordner im Filedialog, die sind wohl egal.

/home/dau/.config/kdeglobals:dbfile=/home/manfred/.mozilla/firefox/ygw1vr8x.default/places.sqlite

Das ist nur interessant wenn du nach Firefox Bookmarks in KRunner oder dem Anwendungsmenü suchen willst.
Du kannst die Zeile aber auch komplett aus kdeglobals rauslöschen, dann sollte sie automatisch richtig gesetzt werden.

/home/dau/.config/akonadi/akonadiconnectionrc:UnixPath=/tmp/akonadi-manfred.JbsChy/akonadiserver.socket
/home/dau/.config/akonadi/akonadiserverrc:Options="UNIX_SOCKET=/tmp/akonadi-manfred.JbsChy/mysql.socket"

Sollte auch egal sein, das ist nur ein Pfad zu einer temporären Datei in /tmp, der Ordner wird sowieso automatisch angelegt.

/home/dau/.config/teamviewer/client.conf:[strng] Meeting_UserName = "manfred-tuxedo"
/home/dau/.config/konversationrc:Ident=manfred
/home/dau/.config/konversationrc:Nicknames=manfred,manfred_,manfred__
/home/dau/.config/konversationrc:Realname=manfred[/QUOTE]
Diese Usernamen bzw. Nicknames sollten ja noch stimmen, auch wenn du den Benutzernamen des Linux-Systems geändert hast.


Übereinstimmungen in Binärdatei /home/dau/.config/q4wine/db/generic.dat.
/home/dau/.config/q4wine/default.conf:prefixDefaultPath=/home/manfred/.local/share/wineprefixes


Die zweite Zeile könnte problematisch sein falls du q4wine verwenden willst, solltest du vermutlich anpassen.
Die erste Zeile scheint irgendeine Datenbank sein. Die sollte wohl neu aufgebaut werden.
Ich hab q4wine aber noch nie benutzt also kann ich nichts genaueres sagen.

Die Vivaldi-Sachen sind nur Logfiles (also egal), der Rest wie gesagt zuletzt benutzte Dateien/Ordner.

Und auf was genau ist die Einstellung jetzt?

Ich glaube schon, dass ich das richtig gemacht habe:
Einstellungen für Ordneransicht wieder auf “Ordneransicht” eingestellt
Bei “Orte” steht i.M. “Arbeitsflächenordner anzeigen”

Interessanterweise kommt die Fehlermeldung wieder, wenn ich “Ort anzeigen: Home” verwende.

Wenn ich den Desktopordner explizit angebe (mit “Ort angeben”) kann ich zwar den Desktopordner auswählen, aber es ändert sich nix im Vergleich zur jetzigen Enstellung “Arbeitsflächenordner anzeigen” (warum auch). Eine Fehlermeldung gibts in der Einstellung ebenfalls nicht.

Ich habe noch spasseshalber versucht einen neuen Ordner mit dem Inhalt von “Desktop” anzulegen und exlizit auf diesen zu verweisen, funktioniert aber ebenfalls nicht, ohne Fehlermeldung.

Dann wird der Ordner verwendet, der in Systemeinstellungen->Anwendungen->Pfade gesetzt ist.

Interessanterweise kommt die Fehlermeldung wieder, wenn ich “Ort anzeigen: Home” verwende.

Du hast ja erwähnt dass du in Dolphin’s “Orte” zwei Home hast, das neue und das alte.
Diese Orte hier sind die selben wie in Dolphin, dieses Home ist dann wahrscheinlich der alte Eintrag.
Ich würde dir empfehlen diesen Eintrag in Dolphin zu löschen (rechts-klick).

Allerdem ist Home sowieso nicht das gleiche wie $HOME/Desktop…

Wenn ich den Desktopordner explizit angebe (mit “Ort angeben”) kann ich zwar den Desktopordner auswählen, aber es ändert sich nix im Vergleich zur jetzigen Enstellung “Arbeitsflächenordner anzeigen” (warum auch). Eine Fehlermeldung gibts in der Einstellung ebenfalls nicht.

Dann poste jetzt bitte endlich ein Bildschirmfoto.
Was bedeutet genau die Icons sind “unsichtbar”?
Wenns keine Fehlermeldung gibt sollte der Inhalt des Ordners angezeigt werden

Außerdem poste mal ein Inhaltsverzeichnis des Desktop-Ordners:

ls -la /home/xxx/Desktop

(oder wie auch immer der gewünschte Ordner heißt)

Und schau auch dass die Miniprogramme nicht gesperrt sind (rechts-klick auf den Desktop, im Menü sollte dann entweder “Miniprogramme sperren” oder “Miniprogramme entsperren” erscheinen, ersteres sollte der Fall sein).
Wenn sie gesperrt sind, kann man nämlich keine “Verknüpfungen” anlegen.

PS: du hast ja auch Icon-Miniprogramme angelegt. Evtl. sind deine Dateien aus dem Desktop-Ordner dahinter versteckt?
Probier die mal zu verschieben oder löschen. (um die Seitenleiste erscheinen zu lassen musst du auf das Miniprogramm klicken und die Maustaste für ca. 1 Sekunde gedrückt halten, dann kannst du das Widget verschieben oder auch entfernen)

Puh, ich glaube, nun ist es gelöst - ich habe in Dolphin den falschen Persönlichen Ordner gelöscht, und nun sind die Icons wieder da!

Danke für die geduldige Hilfe.

Leider gibst noch ein weiters Problemchen mit nicht aufslösbaren Abhängikeiten, dafür muss ich dann später nochmal einen Thread aufmachen. Das hatte ich neulich mit 13.2 schon mal, ich hoffe, dass es wieder nur an falsche eingestellten Paketquellen liegt, die poste ich dann gleich mit.

Freut mich! :slight_smile:

Leider gibst noch ein weiters Problemchen mit nicht aufslösbaren Abhängikeiten, dafür muss ich dann später nochmal einen Thread aufmachen. Das hatte ich neulich mit 13.2 schon mal, ich hoffe, dass es wieder nur an falsche eingestellten Paketquellen liegt, die poste ich dann gleich mit.

Ja bitte.

Falls es sich aber um das nvidia Repo handelt: das ist momentan kaputt, da hilft nur warten bis die Leute von NVidia es reparieren…