kiwi-ng issue


I’m new to this forum. My apologies in advance if I am not posting in the correct place.

I am using kiwi-ng for image creation on rhel 8.3. I figured I’d try my luck in this Suse forum since I believe kiwi-ng comes from Suse ? One of my local repos has the following settings (under /etc/yum.repos.d/):


In my kiwi config.xml I have specified the following for this repo:

<repository type="rpm-md" alias="local_mariadb" repository_gpgcheck="false" package_gpgcheck="false" priority="1">
    <source path=""/>

I don’t see any way to specify module_hotfixes attribute in my kiwi config.xml. It’s not recognized.

When kiwi sets up this repo, I can see this attribute is missing:

cat /var/cache/kiwi/dnf/repos/local_mariadb.repo

name = local_mariadb
baseurl =
priority = 1
repo_gpgcheck = 0
gpgcheck = 0

This results in module filtering issues, and no luck installing the mariadb rpms.

Am I missing something here ? Is there any way to get kiwi to add this attribute when setting up this local repo ?

Thanks in advance,