kinternet cfg with multiple ISPs

CFG: openSuSE 11.0 / KDE 3.5.9 / Thinkpad T43 / USRobotics USB serial modem

I need to use two different dialup internet providers.

My attempts:

YaST2 | Network Devices | Modem

NetworkManager is enabled. Some features, such as
multiple providers for one modem, will not work.
You may want to use kinternet instead.

Click OK.

YaST2 loads: Modem Configuration Overview with tabs Modem Devices | Providers. Modem0 (the USB USRobotics serial modem) is listed with one of the providers. This configuration can be used successfully.

I click the Providers tab and see both providers listed. One has been set up using the Custom procedure, the other is Earthlink, selected from the providers menu, with a local phone number that I entered.


  1. Does the YaST warning message intend to suggest that NetworkManager shouldn’t be enabled and that I should use kinternet in its place? Or should NetworkManager be left enabled?

  2. When I right click on the kinternet icon in the toolbar, I see a Provider menu option. It lists only the first provider. Should I expect to see both with the option to pick one?

  3. Is there some other way of configuring options in the kinternet aplet that I should be using?

  4. On a KDE site, I’ve seen their intention to remove kinternet. Is there another GUI feature that I can use for phone dialup that supports multiple ISPs?

I haven’t used dial-up for a while, but the message is telling you that it is not using the traditional ifup settings.
Try going to yast>net devices>net settings.
Click on global tab and set the network to Trad Method with ifup.
Ater this configure the modem.

Thanks for the pointer which did allow me to get at least an elementary understanding of the ifxxx processes. I don’t understand clearly however how the values in these files get configured and how they drive the kinternet aplet.

In the last lines of /etc/sysconfig/network/config I find this brief explanation:
Instead of the usual network setup (now called ‘NetControl’) you may also use ‘NetworkManager’ to control your interfaces.

This is followed by a short explanation of conditions under which it would be best to use NetControl and NetworkManager; that the former is not a GUI tool and that the latter is. If there is a cmdline configuration application called NetControl, I can’t locate it. If this is just a process of modifying the ifxxx files with a text editor, I can’t seem to do that in a way that is reflected when I later run kInternet. For example, I have deleted several unnecessary files in the etc/sysconfig/network/providers directory, but these deletions aren’t recognized in the kInternet | Provider menu.

Using YaST | Network Devices | Modem to configure a single setup, it lists the configured modem with Earthlink, but kInternet log shows it dialing the other provider’s phone number and using the password for that account. I don’t seem to be able to trace how/which scripts are loading information from the configuration files for kInternet.

Perhaps I’ve missed a useful how-to or other documentation about how the ifxxx and kInternet are configured and controlled, but right now I’m effectively puzzeled.


And the above behavior was based on setting YaST | Network | Network Devices | Network Setting method to ‘Traditional Method with ifup’.

I don’t really understand your problem. I have (in the past) used multiple access numbers for the same provider, which were entered by running the Yast / Network Devices / Modem “wizard” once for each access number.

And then all the various access numbers were listed when I right-clicked on the Kinternet icon and looked under “providers”.

I always ignored the warning dialog you mentioned and did nothing to try to disable Network Manager, and everything worked fine.

Lately though, I have been disabling Network Manager and using “traditional ifup method” simply to get rid of those annoying “Firefox is in Offline Mode” messages. Disabling Network Manager gets rid of these, but has no other effect that I have noticed.

Have you tried setting up each provider using “custom” settings and not using the special Earthlink settings? To do this, I belive you click the “providers” tab, and then “new” and then “use custom settings”.

This could very well be a bug, since in OpenSuse 11, the Yast / Modem configuration dialog used to every time crash at the end of the procedure. So it would not surprise me if other bugs cropped up.