Kino and raw1394 on 11-KDE4

OK, discovered that suse puts the raw1394 file in a different location and under a different name than what Kino is expecting. Kino looks for it in /dev, suse puts it in /usr/lib64 and names it p, li { white-space: pre-wrap; } or p, li { white-space: pre-wrap; } Kino launched the first time, but of course couldn’t see the 1394. So I tried creating a symbolic link which didn’t work, and now Kino will not load at all. I’ve tried reinstalling Kino, removed the link and nothing seems to work. From my reading on this forum it looks like suse decided to move this file almost two years ago. Any help will be much appreciated. I don’t want to have to install another distro, but video editing is a must.

When removing kino, check also for a hidden configuration file under /home/youruser-name/. (where a dot precedes any hidden files)

Thanks for the response. Yup, I deleted that one also. Has anyone gotten Kino working on 11 with KDE4?

I installed KDE3.5/suse11 and Kino saw the firewire right away. I didn’t even have to change permissions or ownership. Still would like to get it working on 4, however.

OK, this is a bit embarrassing… apparently all you have to do in suse is have the camera on and it figures out how to point Kino at the raw1394 file. Guess I am use to other distros where you have to chown and chmod the file in order to access it. I am getting more and more impressed with the 11 release.

Great! Glad to read you sorted this.

Congratulations, and thank you for sharing your solution!

I still think there is a bug / problem here somewhere.

Like you, after installing Kino I got the raw194 file not found.
I am using KDE 3.5.xx

Tried plugging in camera and restarted Kino - same message.
Tried rebooting - same.

Removed Kino - reinstalled it with camera plugged in - same.
Rebooting - same.

Removed Kino, deleted hidden folders associated with Kino.

Reinstalled Kino with camera plugged in and everything is detected nicely.

Looks like a problem here where Kino needs to be installed first time with the camera plugged in and on otherwise things get screwed up.

Don’t recall anything like this issue in 10.3

Could be, I don’t remember if I had the camera plugged in the first time I installed Kino or not. Might be the installer assumes that a USB connection will be used unless it detects a ieee1394 and doesn’t install the raw1394 file?

Does kino support USB? The kino web site states:

Kino will not capture the video from a camcorders through a USB interface. However, you ought to be able to acquire still images over USB and use those in Kino.

Oh, never checked that out since all I have is firewire.