Killed a working install in a way that wont let me reinstall

Well this can’t be good, had a working openSUSE 11.1 x86_64 install. Now it gets to the bootscreen and wont go any further. (Monitor is still getting a signal, but not displaying anything).

If I try to install/repair/rescue mode from the DVD it does exactly the same thing after the “loading kernel” progress indicator reaches 100%.

There are several things that might have gotten me in this mess…

  1. I thought I’d save some power by making use of the disk power saving feature my disks support, hell I was even writing an article about it so others could save some money on the electricity bill to.
    Posted it at: the how-to part of the forums, but asked for it to be hidden/greyed out/removed so others don’t end up in this mess. So in case it is deleted, please see pastebin - backup for further info.
    I did this for all my disks openSUSE itself isn’t on. ( sdb, sdc, sdd… all disks in my software raid 5 array ).

  2. Dolphin was saying about missing kio_slave I think… kio something at least!
    So I thought it might be cause I had deleted kio-beagle.
    Tried googling for a solution and found some page that suggested to do the commands.
    rm -vf ~/.kde/share/config/ksyscoca
    kbuildsycoca

    And I did… during the kbuildsyoco the system hang and I forced it to reboot with the reboot button.
    That’s how I ended up in this situation.

  3. I was interested in updating my bios so I installed coreutils and performed some command I can’t remember… anyways, it made a backup of my bios… and since this BIOS appears to be fine I doubt this is the cause.

I tried… disconnecting all disks but the one openSUSE is on.
A different monitor
Different monitor on DVI connector instead of the old err VGA? connector.

No luck, keep getting the same ‘dead’ screen.

I think it’s a hardware problem of some sort. I don’t think your powersaving tip did it, just bad luck that the hardware problem happened at the same time.

Can you load the rescue system in text mode so that you can see where it gets to?

It’s working again… but I am clueless as to why.

I reconnected all the disks again, set the right one as second boot device, saved changed in the bios and suddenly it’s booting.
Or well, it should after it’s done fixing the filesystem.

Would you mind giving the article a good look to confirm it doesn’t mess up the system as I would like to share the tip if it’s safe to use.

I’d say hardware, too, because the CD boot hung at about the same place (if I’m reading you right). But I’m curious: what error were you getting right at the moment of the hang? Did you get any details with the Kernel panic?

I’d suspect a loose cable or a badly-seated RAM stick. The problem would appear at random, for no obvious reason, then resolve itself and go away. This is what your issue sounds like, just going by what you’ve reported here.

A bad UPS that’s putting out harmonics (or allowing power company glitches to pass through) can cause issues at random. Not very likely, but we’ve had this once or twice.

And of course, if it happens again, I guess it’s possible that the mobo is bad. While statistically, any motherboard can fail over time, in my experience, that really only happens if the unit has been jarred or dropped.

Got nothing, just a blank screen…

My SDA’s file system is corrupted again, /sigh so I’m having a hell of a time trying to just boot it, as I might see something in the logs after I can boot?

Think my laptop not shutting down NFS properly keeps corrupting it as it is the disk I got mounted as NFS usually.
Trying the repair option from the DVD atm instead of a running the fsck command, hope that goes better…