Kill unkillable task?

On my server openSUSE 11.1 x86_64 KDE4.1 I got kacpi_notify taking up 50% of the cpu and zypper taking up 300MB of RAM which seems to be steadily growing…

How do I kill these 2 as system monitor > Kill process doesn’t do much besides asking for a root password.

I’m reluctant to reboot as this will no doubt result in a disk error + 6 hour recovery process, for which I quite frankly don’t have the time. Don’t like the console view much either as the resolution isn’t supported on the monitor on the server, but I can drag my normal one to it.

First of all, I would fix this issue. It´s not that good of an idea to let your PC run forever. SOME day, your computer will take the nap it always wanted…

As for your personal problem:

I would recommend you to press CTRL + ESC to call the process monitor. There you will be able to identify your tasks (as well as their PIDs), mark them and kill via the GUI.
Now if that doesn´t work, note down the PIDs and via console type:

kill YOUR-PID

Hope it helps. :slight_smile:

TheMask.

As long as I’m in control of when it isn’t too big a problem as I can plan it when I do have the time.
Thread where I tried to narrow down the constant file corruption problem cause did not get me any satisfactory results so I’ll just get a new harddrive, do a reinstall and see if that solves the problem, but till then I’d like to get rid of these tasks burning resources like there is no tomorrow.

That’s the system monitor I refered to.

Same result as trying to do it trough the gui.
Command execute fine, just doesn’t do anything.

That´s for sure very strange. Have you tried opening a second session as root and killing the tasks likewise from there?
Please tell me: How long has your system been running without rest?

TheMask.

kill -9 pid_of_process

Or, pgrep process-name, that’ll give you the ID, then kill with that.

If processes are refusing to die, they’re probably already hung. Entering “shutdown -r restart” as root at the CLI to force a reboot should be reasonably safe, too.

Axeia wrote:
> On my server openSUSE 11.1 x86_64 KDE4.1 I got kacpi_notify taking up
> 50% of the cpu and zypper taking up 300MB of RAM which seems to be
> steadily growing…
>
> How do I kill these 2 as system monitor > Kill process doesn’t do much
> besides asking for a root password.
>

last time i check, kacpi_notify was part of kernel process. i think you
should not kill it. just try to stop/kill zypper and see if kacpi_notify
still taking up the cpu.

> I’m reluctant to reboot as this will no doubt result in a disk error +
> 6 hour recovery process, for which I quite frankly don’t have the time.
> Don’t like the console view much either as the resolution isn’t
> supported on the monitor on the server, but I can drag my normal one to
> it.
>

btw, how do you assume that reboot will result in disk error ? maybe it
was just fsck process.

It did that the last 8 out 10 reboots :wink: the 2 where it didn’t it wasn’t running for longer then a few minutes at most.

Oh well got the rpm process killed, acpi is still at 50-65% cpu load, but I can live with that for now.

I was bored so a did some googling.

https://bugs.launchpad.net/ubuntu/+source/acpi/+bug/75174

That’s from the Ubuntu forum and the unit in question is a laptop, but that sounds suspiciously like your kacpi-notify problem. Just like you, even a kill -9 won’t make it die, and then the computer hangs, requiring a hardware reboot.

They recommend that you disable acpid (the acpi daemon) before shutting down.

Interesting.

Still don’t know about your other problem.