Kickoff Launcher loosing transparency after update


I’ve recently installed openSUSE again and on first boot the kickoff laucher looks like this.

I then proceed to update the system. After I have downloaded and installed all the updates from yast online update I then restart and when I boot in the kickoff laucher has lost it’s transparency?

I don’t have any extra repos added apart from the defaults when installed. And I’m using the Intel graphics driver.
Is there perhaps a desktop effect module being turned off?
Thanks for the help.

Turning effects off will have that effect.
If you try switching effects on, what happens?

The desktop effects are already enabled in the System Settings. So I tried disabling and reenabling them and resetting to defaults. It seems I have most of the usual desktop effects like the minimise effect, window glow, menu bar transparency, and transparency on window move but not that transparency effect on the kick off launcher.

Try changing to a a different desktop theme
Air openSUSE?

Changing desktop theme around and back to Air openSUSE doesn’t seem to fix it either.

If effects are working then you need to wade thru the settings
Test a new user login, see if it’s the same

A new user was the same as well. I tried turning on and off desktop effects to see if I could find the one it could be but was not able to get the launcher transparent how it was.
I get the feeling that a update has broken something. As a clean system it’s fine but as soon as I zypper patch and get all updates and restart it becomes like this.

Check your settings here
SUSE Paste
I don’t mean to set them like that, because I don’t use effects. But maybe you can try something there.

Yeah that module was ticked and had the same settings as that screenshot. Turning off that module made windows stay fully opaque when moving windows. I had a play around with the settings but was unable to get the intended effect.

Do you have this installed


It should give you some more options Eg: glassified, slim-glow

Installing that has given me the Slim Glow theme to choose from in Desktop Themes. I tried that one out and the kick off launcher is transparent again albeit using the black slim-glow style.
I wonder then if it is my air desktop themes that might be at fault then and I wonder if removing and reinstalling the air themes might fix the problem?

I wonder if removing and reinstalling the air themes might fix the problem?
Very unlikely.

Are you using any other repos?

zypper lr -d

Just the usual repos you get by default when you install.

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
2 | openSUSE-11.4-11.4-0 | openSUSE-11.4-11.4-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-ATAPI_iHAS124_B_3524223_3F8115501057,/dev/sr0 |
3 | repo-debug | openSUSE-11.4-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.4/repo/oss |
4 | repo-debug-update | openSUSE-11.4-Update-Debug | No | Yes | 99 | NONE | Index of /debug/update/11.4 |
5 | repo-non-oss | openSUSE-11.4-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/non-oss |
6 | repo-oss | openSUSE-11.4-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/oss |
7 | repo-source | openSUSE-11.4-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.4/repo/oss |

I tested
Air openSUSE

Both work here. Air has panel transparency too.

I wasn’t able to find and option for panel transparency but I did find under Dektop Themes->Details that you can set what the panel background is and what Kickoff launcher there is. All of which are set to the default values of “Air OpenSUSE”.
Maybe the problem is with the desktop effects and the Intel driver? I’ve tried other distros with this same machine and the desktop effects have worked out the box and so did OpenSUSE till I fully updated it.

I take it desktop cube is working and stuff like that?

I am using a different version of kde than you but I only moved here very recently from the same as you have. And it was fine.
The intel graphics are the same as mine and I never have trouble with them and I am full updated.

Desktop Cube effect works perfectly.

Maybe I should try doing an update to a newer version of KDE.

Ok have fixed it now.
Installing KDE 4.6.5 has fixed this now.

Thank you so much caf4926 for your help, I owe you a beer :slight_smile:

Moral support on this one I think.
Happy to hear it’s better now