Kicked out of X session on login

Today I stopped being able to log in to Gnome 3 on OpenSUSE 13.1. When I enter my password, I get kicked out immediately and find myself back at the login screen.

This is /var/log/messages after I try to log in (a longer version is here):

2014-12-25T17:28:16.368773+01:00 ondra gdm-password]: pam_unix(gdm-password:session): session opened for user ondra by (unknown)(uid=0)
2014-12-25T17:28:16.370671+01:00 ondra systemd[1]: Starting user-1000.slice.
2014-12-25T17:28:16.371095+01:00 ondra systemd[1]: Created slice user-1000.slice.
2014-12-25T17:28:16.371711+01:00 ondra systemd[1]: Starting User Manager for 1000...
2014-12-25T17:28:16.373705+01:00 ondra systemd[1]: Starting Session 3 of user ondra.
2014-12-25T17:28:16.374616+01:00 ondra systemd-logind[1972]: New session 3 of user ondra.
2014-12-25T17:28:16.375140+01:00 ondra systemd-logind[1972]: Linked /tmp/.X11-unix/X0 to /run/user/1000/X11-display.
2014-12-25T17:28:16.375670+01:00 ondra systemd[1]: Started Session 3 of user ondra.
2014-12-25T17:28:16.376117+01:00 ondra systemd: pam_unix(systemd-user:session): session opened for user ondra by (uid=0)
2014-12-25T17:28:16.386869+01:00 ondra systemd[3712]: Failed to open private bus connection: Failed to connect to socket /run/user/1000/dbus/user_bus_socket: No such file or directory
2014-12-25T17:28:16.455219+01:00 ondra systemd[3712]: Mounted /sys/fs/fuse/connections.
2014-12-25T17:28:16.455632+01:00 ondra systemd[3712]: Stopped target Sound Card.
2014-12-25T17:28:16.455896+01:00 ondra systemd[3712]: Stopped target Bluetooth.
2014-12-25T17:28:16.456073+01:00 ondra systemd[3712]: Starting Default.
2014-12-25T17:28:16.456374+01:00 ondra systemd[3712]: Reached target Default.
2014-12-25T17:28:16.456721+01:00 ondra systemd[3712]: Startup finished in 69ms.
2014-12-25T17:28:16.456995+01:00 ondra systemd[1]: Started User Manager for 1000.
2014-12-25T17:28:16.666275+01:00 ondra org.a11y.Bus[2416]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
2014-12-25T17:24:44.498774+01:00 ondra gnome-session[2343]: message repeated 4 times:  (gnome-settings-daemon:2668): GLib-GObject-WARNING **: value "100.000000" of type 'gdouble' is invalid or out of range for property 'percentage' of type 'gdouble']
2014-12-25T17:28:16.666689+01:00 ondra gnome-session[2343]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
2014-12-25T17:28:16.666974+01:00 ondra org.a11y.atspi.Registry[2535]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
2014-12-25T17:28:16.670887+01:00 ondra gnome-session[2343]: (gnome-settings-daemon:2668): GLib-GIO-WARNING **: Error releasing name org.gnome.SettingsDaemon: The connection is closed
2014-12-25T17:28:16.671113+01:00 ondra gdm-launch-environment]: pam_unix(gdm-launch-environment:session): session closed for user gdm
2014-12-25T17:28:16.671445+01:00 ondra ca.desrt.dconf[2416]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
2014-12-25T17:28:16.676767+01:00 ondra xdm[2015]: Failed to remove slave program access to the display. Trying to proceed.
2014-12-25T17:28:16.678153+01:00 ondra colord: Automatic remove of icc-3247ef85ac3aca108a18f565aae5186f from xrandr-Fujitsu Siemens Computers GmbH-P15-1A-YEBK204250
2014-12-25T17:28:16.678508+01:00 ondra colord: Profile removed: icc-3247ef85ac3aca108a18f565aae5186f
2014-12-25T17:28:16.678701+01:00 ondra colord: Automatic remove of icc-a4264fcfa733140182a5d0986b3bee6d from xrandr-LVDS1
2014-12-25T17:28:16.678886+01:00 ondra colord: Profile removed: icc-a4264fcfa733140182a5d0986b3bee6d
2014-12-25T17:28:16.679068+01:00 ondra colord: device removed: xrandr-LVDS1
2014-12-25T17:28:16.679249+01:00 ondra colord: device removed: xrandr-Fujitsu Siemens Computers GmbH-P15-1A-YEBK204250
2014-12-25T17:28:16.681500+01:00 ondra kernel:   247.379203] show_signal_msg: 87 callbacks suppressed
2014-12-25T17:28:16.681518+01:00 ondra kernel:   247.379209] gnome-shell[2968]: segfault at 7f9bea877fd0 ip 00007f9be60be715 sp 00007fffd092ada0 error 4 in[7f9be6045000+1a5000]
2014-12-25T17:28:16.689453+01:00 ondra polkitd[2022]: Unregistered Authentication Agent for unix-session:1 (system bus name :1.24, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8) (disconnected from bus)
2014-12-25T17:28:16.697354+01:00 ondra /etc/gdm/Xsession[3719]: /etc/X11/xinit/xinitrc.common: line 92: xmessage: command not found
2014-12-25T17:28:16.697752+01:00 ondra /etc/gdm/Xsession[3719]: /etc/X11/xinit/xinitrc.common: line 1: exec: xterm: not found
2014-12-25T17:28:16.697933+01:00 ondra gdm-password]: pam_unix(gdm-password:session): session closed for user ondra
2014-12-25T17:28:16.734802+01:00 ondra systemd-logind[1972]: Removed session 3.

What could be the problem?

And you are very, very sure, nothing was changed on the system shortly before you got the problem? No software updates, no instrallations/removals, nothing?

I did install a bunch of libraries and Python packages because I was building Sage from source. Some software updates might have been installed as well.

Yesterday I formatted the OpenSUSE partition and installed OpenSUSE 13.2. It worked, I updated everything, installed some new packages, restarted a few times, still worked. Then a weird thing happened: the X session suddenly quit and the login screen didn’t reappear so I rebooted using a terminal. Then it worked for a while again and then I got a black screen out of nowhere. I couldn’t do anything so I had to do a hard reboot and then I got the same problem as I described in my previous post. This is strange. Could it be that the hardware is somehow failing?

To me, these sort of intermittend hickups sound like hardware. But I am not sure.

Maybe, to increase the information in this thread for others, look in loggings. And add infomation about your Graphics card. Check your memory. Check your disks. Just some wild suggestions.