KGpg - not decrypting / no passphrase prompt


I installed:

openSUSE 11.0 (i586)
Linux i686
KDE 4.0.4 (KDE 4.0.4 >= 20080505) “release 15.2”

and KGpg, then imported my KGpg key from my key backup.

The problem is when I right-click on an encrypted file in Dolphin and select Open With KGpg, nothing happens. The cursor changes to the KGpg “processing” cursor, but I don’t get a passphrase prompt and the file doesn’t get decrypted. I get the same result if I click on the file or drag it into the KGpg window.

Is this recoverable, or is my data lost?




Seems there’s a problem with importing keys.

I created a new keypair, encrypted a file and had no problems decrypting it.

When I tried to import a key, it keept saying:
No key imported…
Check detailed log for more infos

I couldn’t get the details to show, and couldn’t find a log file anywhere.

After bumping around the program a bit, I went to File > Key Server Dialogue. I didn’t do anything except close the window, and the key I tried importing suddenly appeared in my list of keys. Decrypting my files are now as expected.