kf5.kinit.klauncher: new app spam

Hello,

I am getting a huge amount of spam in my .xsession-errors-:0 file coming from kf5.kinit.klauncher. It is quite annoying since it forces writes to hd so it can never spin down when I am not using the computer. Also the file tends to grow a lot with time.

The error message is


kf5.kinit.klauncher: new app ":1.3310"
("605800", "605799", "605798", "605797", "605796", "605795", "605794", "605793", "605792", "605791", "605788", "605785", "605782", "605781", "605780", "605779", "605778", "605751", "605746", "605745", "605744", "605742", "605741", "605740", "605739", "605738", "605737", "605736", "605735", "605734", "605733", "605732", "605731", "605730", "605729", "605728", "605727", "605726", "605725", "605724")
kf5.kinit.klauncher: new app ":1.3311"
("605723", "605721", "605720", "605719", "605718", "605717", "605716", "605715", "605713", "605712", "605711", "605710", "605709", "605708", "605706", "605701", "605700", "605698", "605694", "605688", "605682", "605681", "605677", "605674", "605664", "605663", "605648", "605631", "605630", "605621", "605620", "605553", "605552", "605550", "605541", "605540", "605539", "605537", "605536", "605533")
kf5.kinit.klauncher: new app ":1.3312"
("605528", "605525", "605520", "605518", "605517", "605516", "605515", "605514", "605513", "605512", "605511", "605510", "605509", "605508", "605507", "605506", "605504", "605502", "605500", "605499", "605498", "605495", "605493", "605492", "605491", "605489", "605487", "605484", "605370", "605349", "605339", "605336", "605335", "605334", "605331", "605329", "605322", "605310", "605304", "605298")
kf5.kinit.klauncher: new app ":1.3313"
("605297", "605296", "605295", "605294", "605293", "605292", "605290", "605288", "605287", "605283", "605282", "605275", "605274", "605272", "605271", "605270", "605269", "605268", "605267", "605266", "605265", "605263", "605262", "605261", "605260", "605259", "605258", "605257", "605256", "605255", "605254", "605253", "605251", "605250", "605235", "605234", "605232", "605228", "605227", "605224")

and so on. Can anyone help eliminating the culprit?

Well, the “culprit” is probably having debug output enabled.
Try to disable it in kdebugdialog5.

I was actually getting suspicious that something was wrong with my system. As a matter of fact, for whatever reason also the kdeinit daemon from kde4 was starting. Solved it by recreating a new user and transferring my files.

That’s not unusual really.
It is still used/needed for KDE4 based applications, in particular if you start them via the session management I think.

Both are designed to run concurrently.