Keyring Manager gone on strike

It appears that my keyring manager has gone on strike. I did a “zupper up” today and ever since doing that, the computer has not asked me to enter my default keyring password when booting up. The only way for me to connect to my wireless is to enter the WPA security code every time and when loading Pidgin I have to enter all my passwords. This is very annoying!!! I have deleted my default.keyring file, restarted and it is not asking me to enter a new password. HELP PLEASE! Oh… I’m very new to opensuse.

I restored default.keyring and “default” from the trash bin and now when I restart I get the usuall screen that asks me for the default password, however, it said something like “a program is trying to access the default keyring but it is locked” and it does not give me the option to type in the keyring password. Clicking OK just brings up the window again, clicking a second time on OK brings up the wireless manager and it wants the WPA password. HELP PLEASE