Not to sure if this is the correct area but, here goes.

I have done a full install of leap 15, I came from Leap 42.3 which worked as expected.

I have a Xonar DGX sound card, got that working

I have a Nvidia GTX 1070 card, all now working as it should

I have an Apple aluminium keyboard that has been set up the same as 42.3 which worked then but the shortcuts within firefox and thunderbird do not work. Not to sure if it is throughout Suse or just specific to these two.

I have tried midori as both a user and as root, same result as firefox.

I have checked and changed permissions, same problems

You haven’t mentioned which GUI you’re using: KDE, GNOME, whatever?

Please post the output of the following CLI command executed in Terminal window: ‘localectl status’.

Before I respond, my comparisons to the issues I have had with Leap 15.

My Xonar DGX soundcard and alsamixer. In 42.3 I run alsamixer in a terminal presse F6 to change soundcard, set the levels and then use the alsactl set of commands to save the asound.state file and reload it as a .desktop file. The function key F6 to select the soundcard does not work, not active.

Nvidia driver for my GTX107 works fine in both apart from the Nvidia Settings file, in 42,3 it under section settings. In 15.0 I had to change the permissions from root to myself, make an entry in the KDE menu and then it will work.

Firefox, Midori, Thunderbird, in 42.3 the keyboard short cuts work fine, the function keys, in 15.0 they do not work. For example F5 to refresh web pages works in 42.3 not in 15.0

I am using an apple aluminium keyboard with, you have guessed it, the same settings as 42.3.

I was running KDE from the disc, in my opinion there is something not right when, again in my opinion, it is not working as it should do.

Notice I said was as I have succumbed to the dark side of windows

localectl status
System Locale: LANG=en_GB.UTF-8
VC Keymap: mac-uk
X11 Layout: us

And it is supposed to be set for UK. I have set it to UK in Settings and in YAST

Using KDE

I give up on W10 as the fonts were blurred and I tried to get it working. I just have to get used to leap 15 now. I am getting there

Managed to get the keyboard changed to UK now, all that needs sorting out is the refresh settings for the web

Please check the contents of:

  • “/etc/X11/xorg.conf.d/00-keyboard.conf”

Pay particular attention the values of the following X11 options:

“/etc/X11/xdm/” has the following values for a “mac-uk” keyboard:

# /.../
# Mapping table for console -> X11 mapping
mac-uk          : macintosh : gb       : x            : xfree86 : x : x : x : x : altwin:swap_lalt_lwin,lv3:alt_switch

  • “/etc/sysconfig/keyboard”

Pay attention to the value of “KEYTABLE” – in ‘/usr/share/kbd/keymaps/xkb/’ there are 2 “GB” Apple keymaps:


Please choose the one which applies to your Apple keyboard. Please be aware that, the value used by “KEYBOARD=” does not include the string “.map.gz” which is part of the Keyboard Map’s filename.

Please be aware that, the value of “YAST_KEYBOARD=” should use the string “pc104” despite your keyboard possibly being a ‘PC-105’ variant.

Given that “localectl status” is reporting “System Locale: LANG=en_GB.UTF-8” the chance are that, the contents of “/etc/sysconfig/language” are correct but, you’ll need to check the contents of that file as well.

In your output of “localectl status”, the following values have not been reported by you:

  • X11 Model:
  • X11 Variant:
  • X11 Options:

sorry for the delay.

System Locale: LANG=en_GB.UTF-8
VC Keymap: UK
X11 Layout: gb
X11 Model: microsoftpro
X11 Options: terminate:ctrl_alt_bksp

I did have it working before but now the function keys do not work in Firefox and Thunderbird

EDIT: The keys are in the correct place now. As I just said the function keys might as well not be there as they do not work.

Now changed to:

System Locale: LANG=en_GB.UTF-8
VC Keymap: uk
X11 Layout: gb
X11 Model: pc105
X11 Options: terminate:ctrl_alt_bksp

As I may have said in the first message of this thread.

This is a fresh install of 15.

The order after the installation has finished.

Configure desktop/tweaks unclick the options there
Load dolphin add menu, settings/services click on delete. Delete the 2 icons on the desktop
KDE menu click on system settings. Do a little bit of configuring. Under hardware/Input Devices/keyboard/Keyboard Model I have, Apple | Apple Aluminium (JIS)

Next job, get the sound card working. Open a terminal and enter alsamixer and press F6 to change the sound card to Xonar DGX set the levels. I have script to autoload sound settings at boot.

That all works under 42.3 but not in 15.0 as the function keys are not there.

Please check the shortcut key settings in the KDE System Settings.
Also, please create a “new, fresh” test user, login to that user and, check if the Function Keys are still misbehaving with Firefox for that user – don’t bother about Thunderbird and the associated e-Mail account setups for that user …

I have plugged in a spare usb keyboard and the function keys work but not on the full size usb apple keyboard and this is on a fresh install. In my opinion it appears that leap 15 does not recognise the function keys on the apple keyboard.

I have checked the shortcuts, no problems there.

I have searched the internet for help and tried various “fixes” but the function keys do not work on my Apple keyboard. Yes, I have another keyboard which I class as a thump type keyboard. I prefer the apple keyboards.

I have, also, said that it work flawlessly under leap 42.3. I know that a few people like 15, on the other side of the coin, some people think that 15 is a step backward. In my opinion I think that. If you say I am wrong and you have had no issues, well done, if you have had issues, like me, then you will say that 15 is a step backward. When I was install my hardware under 15, I had sevre dependancy problems with my Epson V39 scanner, under 42.3 it was resolved and took only minutes instead of a lot longer under 15. I would like to use 15 but at the moment I cannot. If you suggest changing keyboard, no thanks I prefer the apple keyboard as it is easier to type on. I have tried the suggestions within this thread, no luck, the functions keys have been removed. I have tried ALL the keyboards within system settings, the major keys work but NOT the function keys.

Thankfully this has been installed on a spare SSD with Windows on the other SSD.

You may have noticed that I am not happy with 15, yes, I could install 42.3 and upgrade but I have a feeling that this problem/issue will occur.

tried that and it made no difference, plus, I have checked the shortcut key settings, as they should be.

I plugged in a spare keyboard and the function keys work on that. The apple keyboard is fine as it works as it should e under Windows.

With KDE Plasma and Leap 15.0, have you checked that, in the “System Settings”, the keyboard model is either “Apple” or, “Apple Aluminium” (ANSI/ISO/JIS)?

Yes I have done that. It is one of the things I do after installation, sort out system settings

Got it solved, it had something to do with fnmode. The fnmode file kept on resetting it’s value to 1, which meant that I had to keep on pressing the fn key and the function key. I added the following to boot parameters before the quiet commant: