Keyboard stopped working

I have a strange problem which has caused my keyboard to stop working when I’m logged as my ordinary user. The keyboard is working fine when I’m logged as root however and also when I run windows (I have a dual boot). Can’t figure out what the problem can be. I’m running 11.0 with KDE4.1.1. Any suggestions?

i aslo have this problem, with kde4.1 and suse11.0

Can you login and use the keyboard from the console so that the problem only occurs when using the window manager?

If the console works, try installing some minimal window manager (windowmaker and icewm both work well). If you can use the keyboard there, the problem is with the configuration for your window manager. You can then remove the configuration files by either ‘rm -rf —’ the directories or ‘mv — —.bak’, then try logging in again.

If that fails, try creating a new user and see if the problem is identical.

Also, can you use the keyboard if root logins first, then your regular user?

As i mentioned in gnome and other desktops i have keyboard!
also in other users i have keyboard!
just in one of users! and in kde4.1 of that user i don’t have keyboard.

i could make a new user! but 10G of my data will be lost and i don’t want that. i want to fix the problem! later it may apeare again!

I would make a new user, which almost surely will not have that problem since root does not have either, and then do the following:

  • make a copy of the .kde4 folder
  • copy back selectively (that is one by one or at least a few per time) from the other users all the folders and files and after each copy restart the X server to check if things work.
    This way you will be able to locate which file or folder contains some screwed setting and you can copy from the backup .kde4 folder that you did to the original users that has problems. So you will keep your user and all your data

Rename the (dot)kde4 directory to (dot)kde4(dot)old, logout+login. The only thing that will be lost is the kde4 settings. Any documents that you might require will still be in the (dot)kde4(dot)old . I would guess there is a file that has incorrect ownership/permissions in the configuration directory.

That would surely work however reconfiguring the whole KDE settings might imply hours of work. Depending on the degree of customization of your KDE, you might want to try re-importing some files to avoid configuring all over again

so the only way is to remove my user?
what’s the problem with KDE?

you do NOT need to remove that user. The problem is somewhere in .kde folder (or .kde4 if you are using kde4).
Go to init 3, that is console, rename the .kde folder that is in your home, then go again in init 5. You will have the default settings for kde, that is all your settings, including the screwed up settings, will be gone, but since your old kde folder is still there (you only rename it, with the mv command, do not delete) you can re-import little by little the old settings, making sure things work fine after each group of settings you re-import

Thanks for the advice. It worked great.