Keyboard shortcuts don´t funcion

Hi
I installed the latest OpenSuse 64bit with Gnome desktop on a Dell Laptop and find out that some shortcuts don´t function, for swiching keyboard-language, open the terminal and the like, how can I fix it?
:sarcastic:
Thanks
Chapati

By latest, do you mean openSUSE 12.3? What is the exact keyboard shortcut you enter that is not working and what is it supposed to do?

Thank You,

Hi !
Yes, I´m using version 12.3.
Shortcuts which don´t functions are for ex: alt+F2 to run application, Alt+TAB to switch between windows. Alt+Shift to switch keyboard language, ctrl+Alt+T to open the Terminal.
Those are the shortcuts I know and normally use but I guess many others don´t function as well.
Those Shortcuts DO function: ctrl+X, ctrl+C, ctrl+V, ctrl+Plus, ctrl+minus.
?

So ALT-F2 should indeed work in GNOME. How long has openSUSE 12.3 been installed? Did you do an upgrade or full install? Has ALT-F2 ever worked or never worked?

Thank You,

chapati wrote:
>
> Hi !
> Yes, I´m using version 12.3.
> Shortcuts which don´t functions are for ex: alt+F2 to run application,
> Alt+TAB to switch between windows. Alt+Shift to switch keyboard
> language, ctrl+Alt+T to open the Terminal.
> Those are the shortcuts I know and normally use but I guess many others
> don´t function as well.
> Those Shortcuts DO function: ctrl+X, ctrl+C, ctrl+V, ctrl+Plus,
> ctrl+minus.
> ?
>
>
All of these commands do work on my openSUSE 12.3/ GNOME 3.6

Alt+F2 (launch new application), Alt+Tab/ Alt+~ (switch between
aplications), meat/win+up (maximize), meta/win+down (restore), Alt+Space
(window menu), left win/meta (or) Alt+F2 (Activities),ctrl+alt+Shift+tab
(Activities switcher)

Can you create a new user and check whether the above key combinations work.

Also check shortcuts registered in Activities ==> keyboard ==> shortucts


GNOME 3.6.2
openSUSE Release 12.3 (Dartmouth) 64-bit
Kernel Linux 3.7.10-1.16-desktop

vazhavandan wrote:

Can you create a new user and check whether the above key combinations work.
Also check shortcuts registered in Activities ==> keyboard ==> shortucts –

I created a new user and all key combinations work there. (only the keyboard language-switch don´t, I guess that I have to create it first…)
I´m a new Suse user, in Ubuntu it worked fine. It´s probably something which doesn´t work automaticly and I have to sett it first, but where, how?
(It´s like the buttons for minimize/maximize a window, It´s my first experience with a Linux where these buttons are missed and I have to tweak it first…)

Normally max/min buttons are there. So you have something set wrong. Are they missing in the rest user also??

Was your home brought with you from Ubuntu? if so the configs for the desk top are probably not compatible.

Wrong. In GNOME3 they are not there by default. That’s an upstream decision by the GNOME developers.

But you can enable them in gnome-tweak-tool (Shell->“Arrangement of buttons on the titlebar”; default is “Close Only”, can be set to “Maximize and Close”, “Minimize and Close”, and “All” as well).

The max/min buttons are missing also in other users.
No, there are no Ubuntu ´rests´, I deleted the hard disk and made complete new partitions for OpenSuse. I also didn´t play with any settings for short cuts and I dont´t actualy know in which settings I have to look for the problem.
:\

Thanks, I already enabled them, with the gnome-tweak-tool it was very easy. If you have an idee how to enable the keyboard shortcuts, that would be great…!

***Since in new “User” key combinations work,something seems to be corrupted on existing user
Can you disable all your extensions/themes if you have installed some and then check whether keyboard short cuts works?

***Did you check check shortcuts registered in Activities ==> keyboard ==> shortucts ?

**- **The shortcuts registered in Activities==>keyboard==>shortcuts seem to be all OK, no different to the settings on other user accounts.
- I didn´t install any extensions/themes, I used the Gnome Tweak tool for changing fonts size etc.-I used it in the other(guest) account too, to see what happens but the shortcuts still work there…that´s a weird thing…

chapati wrote:
>
> vazhavandan;2591518 Wrote:
>> ***Since in new “User” key combinations work,something seems to be
>> corrupted on existing user
>> Can you disable all your extensions/themes if you have installed some
>> and then check whether keyboard short cuts works?
>>
>> ***Did you check check shortcuts registered in Activities ==> keyboard
>> ==> shortucts ?
> *- *The shortcuts registered in Activities==>keyboard==>shortcuts seem
> to be all OK, no different to the settings on other user accounts.
> - I didn´t install any extensions/themes, I used the Gnome Tweak tool
> for changing fonts size etc.-I used it in the other(guest) account too,
> to see what happens but the shortcuts still work there…that´s a weird
> thing…
>
>
==>Install dconf-editor from terminal

su-
zypper in dconf-editor
exit

==>open dconf editor from Activities

==>Navigate to schema/tree org.gnome.desktop.wm.keybindings and try
setting the keybindings/keyboard shortcuts there and resetting them.


GNOME 3.6.2
openSUSE Release 12.3 (Dartmouth) 64-bit
Kernel Linux 3.7.10-1.16-desktop

Hi
Thanks for trying to help. I installed dconf editor but all keybindings/keyboard shortcuts are on default mode and seem to be correct.

If enabled, disable nautilus desktop using tweak tool
try restarting shell (Alt+F2 , type in r and press return/enter)
Now try keyboard shortcuts

Still no success…
I disabled Nautilus desktop with the tweak tool (by checking off “have file manager hanle the desktop” and restarted my laptop but still no shortcuts…

chapati wrote:
>
> Still no success…
> I disabled Nautilus desktop with the tweak tool (by checking off “have
> file manager hanle the desktop” and restarted my laptop but still no
> shortcuts…
>
>
It is probably easier to move contents to a “new” profile where
shortcuts do work :slight_smile:


GNOME 3.6.2
openSUSE Release 12.3 (Dartmouth) 64-bit
Kernel Linux 3.7.10-1.16-desktop

I guess your are right, that´s what i´m going to do.
(Is it possible “to move contents” a kind of ´automatically´ or do I have to reinstall things?)
Thanks for your help!

Just copy things from your home to the new home (avoiding copying anything gnome related). But you will then need to change ownership to the new users UID fo anything you do copy…

You may also try renaming any gnome related directories (note should be done from a terminal without the GUI running. Otherwise like change a tire while driving down the road). When you log back in you should have the default desktop and all should work. Sorry I run KDE and don’t know the gnome directories anymore, but they will be hidden and I assume have gnome in the name

AFAIK GNOME3 just uses ~/.config and ~/.local, so I would try to rename those two first so the settings are not found. If shortcuts are working then, you can copy back the subdirectories one by one.

But as gogalthorp said, better do that when GNOME is not running, you could maybe use IceWM so you don’t have to do it in text mode. Btw, mc is a good file manager for text mode…:wink: