Keyboard shortcut for unicode characters?

On SuSE 10.0 I used to be able to use shift + ctrl + unicode code. That does not seem to work now. How can I get this feature again? I miss it. I used to use it a lot to put the copyright symbol over my artwork in Gimp.

When I need a © I type the compose key (Shift-RightCtrl in my desktop) and then o and* c*.

But that is only for this (and similar or other accented characters much used in western languages) and not for the whole Unicode range.


option A) (using GNOME)
Go to Computer>Control Centre>Keybord=Keybord Preferences>

A1) Register:Layouts > Print
To print your actual layout/combination

In my configuration

  • the “Alt Gr” gives me level 3 (on that printing the symbols down right on each key/button)
  • the “Alt Gr"AND"Caps/Capital letters/↑” gives me level 4 (on that printing the symbols up right on each key/button)

so “Alt Gr"and"Caps/Capital letters/↑"and"c” gives me “©”

Maybe also
A2) Register:Layouts > Print
To change your actual layout/combination

option B)
use a input-pad like the one of SCIM (came with korean letters?) Register: Symbols; Subregister: Letterlike


AltGr_shift_C will produce © on many layouts.

ctrl > shift > U codeunicode
example ctrl > shift > U 0338 gives R̸

What is AltGr?
unfortunately ctrl > shift > codeunicode does not work anymore for me. Like I said, it used to work for SuSE 10.0 but does not seem to be enabled on SuSE 11.2.
I’m using KDE 4 as my desktop environment. I can’t seem to find the way to add this ability to use unicode. How did SuSE 10.0 do it right?

This looks nice (and it seems that you type the number in hex), but where did you switch that on?

On my keybord and with my configuration (you may print yours - see above)
it is the key right of the space bar.
More on
AltGr key - Wikipedia, the free encyclopedia


(Shift-Right Ctrl then o and c) worked for Kwrite only. I would like for that to work for all my apps (like OpenOffice, and Gimp). At least it’s a start.

In my KDE I could modify my keyboard behavior under
YaST>System Settings>Personal: Regional & Language> Keyboard Layout>register card: Advanced

  • if I would like to change anything :wink:

There is also something about “Key to change to 3. level” - I think your ® might be printed with “3.level” AND “Caps” AND “r”.

Good luck!

As you saw, it works for me in my browser (Konqueror, else I would not show you this in a post. And it does in Konsole, I just tried in Gimp (it being not a KDE applic) and it worked.

I do in fact not know about a place where it doesn’t with one exception. I use a Flash programmed applic on a website. As Flash seems to capture my keyboard (as long as I am in that window of course), it does not work there. It also does not work with the X-windows middle mouse button paste, but that is something different.

Easy enough: éä⁰ß©½

It’s still not working for me.
I saw a lot of “options” in “Configure Desktop> Regional & Language> Keyboard Layout> Advanced”. I had no idea what I should choose to make it so that (Left) shift + ctrl + unicode would give me any of the various characters I need.

Refering to my first post in this thread, when you are only after a possibility to create a © we can try to find a solution in the config where you are looking now, because that is what I have functioning. And I repeat, that works for most characters used together with the Latin character set (accented, and others like © ® ß ¼ used in western european languages).

But when you want a solution where you can type all Unicode values like वर्णमाला I can not help you (though I am interested in a solution). Please tell me if you want to go for the simple one to be able to type © with eas or not.

I’m not sure what gynmart’s question is too. I’ve assigned the compose key to the Menu key (just to the right of Windows key) in the X server settings using the configure desktop utility and I get to all the usual sequences I’m interested in

© Compose o c
€ Compose = C
¥ Compose = Y
ç Compose , c
½ Compose 1 2

And this works everywhere, in terminal sessions, in vim, in browser text boxes. Haven’t tried Flash though, don’t enter data into many of those. Let’s see if mouse button cut and paste works.

½ Compose 1 2

Works fine.

If you are so focused on the unicode
you may install, try and possible use SCIM - Smart Common Input Method Platform.

Under SCIM Setup>IM Engine / Global Setup> Other
you can choose “t-unicode” or “Raw Code” (the second includes many input methods, “Unicode”, “UTF-8”…).

The SCIM help gives me:

Input method for Unicode BMP characters using hexadigits.
Type C-u followed by four hexadecimal numbers [0-9A-Fa-f]
or a Unicode character code.

The right “Strg”+u will then start something…

G. gives me also that homepage: SCIM - SCIM

Much fun and luck in playing it out…:wink:


It could be that particular Flash application. It is a quite eleborate one. A complete geographical editing application.

Yes, that’s what I want, the accented character (like the Spanish ‘n’ with the tilde over it, and some french accented characters as well as the copyright symbol). KCharSelect calleds that set “Latin-1 Supplement”.

Ok, we are there. The question is thus: how to configure the Compose key.

Now I have it as Shift-RightCtrl and ken_yap has it as the Menu key. But I have forgotten how I did it (long, long time ago :shame:) anfd ken_yap says:

… using the configure desktop utility …

Please ken_yap could you give us the call of that utility?

Go to the chameleon, then the spanner labelled configure desktop, regional and language, keyboard layout, advanced, compose key position. I ticked Menu.

Hurray! It worked in Gimp! After setting it up the way ken_yap said, then holding down the menu key and at the same time, hitting o then c made ©.
Now, how do I find out what key combinations would give me the other characters (the n-yay [n with the tilde over it] and other accented Latin characters)?