Keyboard problem

I have a strange keyboard problem. If I enable keyboard repeat from system settings, every key press gets repeated no matter how fast I press the key. For example if I try to type the letter ‘a’ I get ‘aaaaaaaaaaa’. Or if I type ‘mouse’ I get ‘mouseeeeeeeeeeee’. I’ve tried different delay and rate options but that doesn’t change the problem.

If I disable keyboard repeat I can type normally, but it’s very annoying when you can’t for example delete characters quickly.

I’d appreciate any help. Thank You.

pump… anyone?

Not mentioned:
Desktop environment
SUSE version
The clincher: KEYBOARD

What do you expect anyone to do?

I’m running opensuse 11.2 with KDE 4.3. The keyboard is wireless keyboard from Labtec. It has a receiver that is plugged to PS/2 port. The keyboard worked well with my previous distro (Kubuntu 9.04?) but it started acting up when I bought a new computer and installed opensuse to it.

I’m thinking that the problem is caused by the new motherboard or opensuse. I thought about installing a different distro to test whether this is a opensuse specific bug or not though preferably I would just figure this one out and keep my otherwise well functioning Suse installation.


It’s me again. I tried with kubuntu live cd and it has the same problem. This leads me to a conclusion that the problem lies with the motherboard or the keyboard. Or maybe with the combination of the two. My motherboard is Asus P5N73-CM with NForce 630i chipset.

Has anyone else got the same motherboard or a motherboard with the same chipset? And if so, are you using a keyboard with PS/2 connector? Next I probably have to try with a different keyboard, I just have get one first.

Any suggestions are still welcome. Thank you.

No solution - just affirmation that this is not a stand-alone problem. I have a keyboard with randomly repeating keys. It has done this in at least 2 distros. Keyboard is a Dell, USB connector. Gnome desktop installation. Changing repeat rates has no impact. The symptoms are not always indicative of the same issue. Researching this, I found people for whom changing the repeat rate, or otherwise playing with configs, fixed the issue. I’ve also seen forum posts from ppl like myself - for whom the repeat rate was not the issue, but rather it seems to be a real hardware or driver issue.

I’m currently “just living with it”.