Keyboard only works in US mode but set for GB

I am running two laptops, both Thinkpads and looking identical as far as keyboard and case are concerned. They are both running TW on KDE desktop but only one has this keyboard problem.

I am revisiting this as it is driving me mad. One laptop works as it should with GB setting in Yast>Language as GB and a GB keyboard. My other laptop is firmly stuck in US mode although all the settings for GB are correct.

I recall somebody explaining this problem was caused by some other KDE app but cannot find the thread. I want to find it or rather what app causes the problem and if OK remove it so my keyboard works as it should.


I assume you’ve tried changing your keyboard in Plasma Settings rather than YAST?

Do you have IBus installed? I did, and had exactly the same issues. If you do you need to set the keyboard in IBus Preferences (Menu: System =>> Preferences =>> IBus Preferences). I have posted this before and one of the admins suggested simply uninstalling IBus.

That was the thread I failed to re-locate so very many thanks.
Out of interest, what is IBus for and do I need it? If I uninstall will it break my system?
Meanwhile many thanks again,

I have not been able to find any obvious means to edit the ibus-config settings and either my system is different or what I seek has been hidden.
Reading the existing ibus-config file I find the instructions there quite confusing.
As a layman I find this one of the worst examples of finding yet another way to do something which isn’t needed by most, with no clarity of precedence of commands and witnessed conflicts between otherwise good system settings.
Rant over, I shall just disable ibus as I have not found how to edit settings.
My thanks again to JulinaB

It is used for those who use different keyboard layouts frequently, and those that may need to type in a phonetic language (eg Japanese using English letters). Otherwise superfluous for most. I don’t have it installed, but it used by the Gnome DE…

IBus readme…


from the command prompt. Should bring up the configuration applet and then go to the Input Method tab.

Having said that you can probably uninstall IBus without any issues.