Keyboard not responding

Hey guys,

when I logon my useraccount on KDE4/Suse 11.1 my keyboard doesn’t
respond to the keys I’m hitting. However the mouse works fine.
I tried plugging in other keyboards I have, but with the same result.
When I logon my rootaccount the keyboard works again…:sarcastic:

I have no idea what the actual problem is. Can someone help me?

Help is much appreciated!

Thank you in advance.


Try to force a re-install of HAL in packager manager, IIRC that resolved keyboard problem for some upgraders 11.1 to 11.2, so may help you to.

can you please explain to me how I do that?

Open YaST Software Manager, search for hal, right click on the package and choose update, or update all in list uncondiationally.,
May solve it, may not but it cannot do any harm.

Ok, that didn’t work…

any other suggestions?

Denny87 wrote:
> Ok, that didn’t work…
> any other suggestions?


  1. do not log into KDE as root…in my experience that causes more
    problems than it ever solves

NOTE: you may start with either two or three below…your choice as
either may fix it, or not…but, before you begin either, read this:

  1. get the install DVD which matches your installed system (32 or 64)
    and boot from it…before you do, look at this:

click on next, then it jumps to letting you see the various install
screens of the DVD…on the FIRST screen select “Repair Installed
System” and hold your breath…when it is done see if your keyboard
works…if it does not, then boot from the DVD again and go to the
screen in the novell documentation following paragraph 4 and select
“Repair Installed System” and wait, then try your keyboard again…

if that does not work, then:

  1. add a new user, then log in as that user and see if the keyboard
    works then, if it does then you know it is something inside your home
    directory which is messed up and with a lot of patience and use of a
    tool like diff you can probably find and repair the problem…to add a
    user without logging into KDE as root:

–at first boot (from hard drive) green screen type 3 and enter…
–soon you will have a log in prompt, type root and hit enter
–give your root password (you will not see what you type)
–type yast and hit enter…
–navigate Security & Users > User Management > Add and add a new
users with a password (WRITE IT DOWN) the [Finish] and
–type shutdown -r now and press enter
–your machine will reboot, then log in as the new user and see if
the keyboard works…

note: i don’t know what kind of keyboard you have but you mentioned
you had plugged in some others…don’t ever plug or unplug anything to
a mouse/keyboard/printer/serial/parallel port (USB and speaker/mic
ports are ok) while your machine is running, ever…

-good luck-


Can somebody help me with the problem? :frowning:

If it’s KDE4, delete (or perhaps try to salvage) the ~/.kde4 folder.

It’s happened about 4 times with my parent’s PC for user pip. Other users (root, jon, peter) have not had this problem. I’ve not a clue why.

OK, so what happens if I delete the kde folder?
What files will be missing after that or what files should I backup?

You could consider renaming it. KDE will build a new one on login and you could reverse the whole change if it didn’t cure it for you.

I’m afraid I can’t help with identifying the problem part.


Thank you very much guys!
One way that works eliminating this problem is renaming your “kde4” folder. You will have to adjust your desktoplooks again but your keyboard will work after that!

Yep, it’s a “part solution”. I feel sure there must be some element within that folder that could be homed in on but I don’t know where to begin and this at least gets things back to being usable.

I’m running GNOME desktop on openSUSE 11.1 and am seeing exactly these symptoms. Do you have a USB keyboard by any chance?

I’m distressed about finding the following link regarding kernel version and USB:
USB devices not available; unable to enumerate device error

I’ve only worked around this by using a PS/2 keyboard instead but am still seeing A LOT of messages in /var/log/messages about “unable to enumerate USB device on port #” where #=1 or 2.

The last kernel version I had which did not have this problem was (on 32-bit), but when my system was upgraded on 5Dec2009 to version

Some times USB keyboard users find it necessary to go into their PC’s BIOS and change the USB mode to a “legacy” mode.

I’m a newbie to linux. This is only my second post.

I have also had this problem. It seems that KDE in 11.2 sometimes is broken on install or if you install an ATi graphics card driver.

What I did to solve it:

  1. As oldcpu suggested make sure USB Legacy support is enabled in the BIOS. This seems to solve the problem for some users.

Why: USB keyboards are relatively new and some operating systems and/or keyboards are not correctly supported.

On my system I press F2 while it boots to get into the BIOS.

  1. On the openSuse logon screen (not the boot menu called grub) in the bottom left hand corner I chose XFCE session. Then I logged in to root.

  2. On the XFCE desktop I chose Dolphin in the Suse menu.

  3. Make sure ‘Show hidden files’ is enabled. (I think it is in the Dolphin menu)

  4. Delete the .kde and .kde4 folders. (I think they are located in /usr/share )(Don’t worry they will be rebuilt when you boot again :))

  5. Reboot the machine

Note: If you have an ATi graphics driver installed you may want to uninstall it first as it can wreak havoc with USB devices. (Apparently the new driver is better?)

Hope this can be of use to someone.

Just to give some h/w details for the PC here that has displayed these symptoms for one user (on 11.1/KDE4).

The keyboard is PS/2

While the MB does have onboard ATI graphics, this is disabled and a nVidia PCIe card is used.

I’m both relieved and embarrassed to discover that my symptoms (unable to enumerate USB device; connect-debounce error; nonworking USB keyboard) as mentioned above were caused by the aluminum faceplate shorting the shell of the USB port. Pardon the interruption.

Glad to read you have it working now.

Thanks for sharing your solution.