Keyboard & Mouse not responding 11.2

I just installed the new OpenSuSE 11.2 release and after coming up in graphical mode the keyboard and mouse are not responding at all.

After that via a remote login force the machine back to runlevel 3 and this makes it able to login to the console and trying to start sax2 to make a new X configuration.

Well it doesn’t read the old configuration but gets stuck as well.

What do from here !???!:’(

The install was an update from OpenSuSE 11.1.

Actually it might have been better if you did a fresh install over 11.1, the problem with using a updater applet to dist upgrade is that configs dont match up sometimes and the machine has issues.
I would backup if possible and try a fresh install of 11.2

Try to change the name of xorg.conf since openSUSE 11.2 can work WITHOUT it.

Hi, had the same problem here after an update.

I found messages like “Can not find core pointer” in the X11.log
Googling this message came up with the suggestion to include

Option “AllowEmptyInput” “off”

in the section “ServerLayout” in the xorg.conf, which fixed
the problem for me.

Hope this will help you as well.


I found this in my X11.0.log:

(WW) AllowEmptyInput is on, devices using drivers ‘kbd’, ‘mouse’ or ‘vmmouse’ will be disabled.
(WW) Disabling Keyboard[0]
(WW) Disabling Mouse[1]

Adding AllowEmptyInput option to my ServerLayout section in xorg.conf did the trick:

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard1” “CoreKeyboard”
InputDevice “Mouse1” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
** Option “AllowEmptyInput” “off”**
Screen “Screen[0]”

Thanks to you all. :):):slight_smile:

Hi Again,

Just as I thought the AllowEmptyInput is just the work around.
After I deinstalled all packages, which where not upgraded
as there was no replacement in 11.2, I did not need to put
the line in there any more. Quite contrary it caused every
keystroke to be shown twice. I guess for me there was a
leftover xorg package from Buildservice or so which was
the real culprit. I don’t know which one, as I actually
used the package clean to remove many packages.

Also having no xorg.conf works now as it should.


Hi everybody. At the beginning I want to say that my English is poor so sorry for my mistakes :shame:
I’m new in OpenSuse, and today I prime once installed OpenSuse 11.2
After installed, my mouse and keyboarding doesn’t work :frowning: I tried change xorg.conf but I don’t have this file. >:( I have just xorg.conf.install
What should I do?

Spróbuj misiu stworzyć plik xorg.conf, wejdź do init 3 i wywołaj sax2. Powinien stworzyć plik xorg.conf, jeśli i to nie pomoże to dodaj do pliku xorg.conf to co powyżej chłopak powiedział że zadziałało. A propo, następnym razem stwórz nowy wątek lepiej.

I had the same problem with an Asus Eee PC 1000H after performing a live upgrade from 11.1.
I found following article: openSUSE Lizards » Updating in Place From openSUSE 11.1 to 11.2.
In a comment on the bottom of the article, the very same problem is described and had been solved by updating the hal to the factory version.
This solved it also for me.

What if you get this problem when trying to run the installation from the 11.2 installation DVD? Not an upgrade at all, a clean install and I cannot even get past the second welcome screen (the one with the language selection and information text box).

Anyway, the hal seems to be the culprit. Does not matter whether you got a broken version by fresh install or upgrade. Just try the Factory version:

Today I just run the opensuse 11.2 kde live version and did a fresh install from the CD. I decided to you a test machine (thankfully). After the install had completed, kdm loaded, but the mouse and keyboard both wouldn’t work.

I rebooted into failsafe, typed in root and the password. Then ran yast2 command. moved over to the Software Repositories and added the following:

Once the Repo was added to Quit (F9) and went to the Software Management. In there I typed hal. I then hit Alt+V to ensure that I was viewing the Software Version and select to update hal by hitting Shift+>

I can confirm that this worked. This fix should never have been required, so any ideas when the developers will re-do the download CD/DVD to include this latest version of hal?

Thanks guys, this worked for me

I ran into the same problem and fixed it in the following way:

  1. Logged into the machine remotely.

  2. Added most of the community repositories including the ones for KDE and Gnome.

3 Ran a general update:

zypper update

What part of the above fixed the problem I have no clue - but the problem is gone.

Just my two cents…


Hello colleagues.

Just’ve ran into same problem. Installed 11.2 x86_64 via USB keyboard (PS/2 worked only in the very beginning). After the installetioin my ps/2 worked ok - but only until the latest update or so.

Following the thread, I just’ve updated my hal to latest hal-0.5.14-23.3.x86_64.rpm from the Factory repo. And even 32-bit version to hal-32bit-0.5.14-23.3.x86_64.rpm as well. Reboot.

Everything is the same.

Tried the workaround with xorg.conf option (Option “AllowEmptyInput” “off”) - leads to double char entries, so it’s not the option .

Is there any one with the same way of things? Any way to solve it?

UPD: Added

Section “ServerFlags”
Option “AutoAddDevices” “on”

(sax and X11 disabled keyboard and mouse - openSUSE Forums)

Keyboard works for several seconds just to log into system and dies whether I’m logging in or not.

After all, it looks like a major bug for me; I hope the developers have already received the info…

i’ve experinced the same problem (I always perform a fresh install) but the funny thing is that the problem occur on my old P3 macine not on my Intel dual core E6400 one.

I’ve also experienced similar problem on my DELL laptop ONLY when it is docking. The mouse is not actually frozen as above but it is just not visible. I can right-click, lock the PC and the mouse is back.

Had the same problem after upgrade and adding
Option “AllowEmptyInput” “off”
to my xorg.conf file under Section “ServerLayout” fixed it.


I have a similar but only temporary problem, that is, I have no keyboard or mouse after login screen comes up. Then, after about 10 - 15 seconds they return. Curiously I have Keyboard and Mouse right up to the final Login screen and the login screen has a flashing cursor in the password box, but they are not available until the time passes, then everything is fine again - no problems then until I reboot next. The keyboard is a generic PS2 one and the mouse is a USB Logitech Optical.