Keyboard led and some keys

Hi guys! Here’s ALbert ;D I have an asus Gv55vw running with opensuse as unitary OS. I have come keys that doesn’t work like fn + F2 (wireless) + F3 (keyboard led off) + F4 (Keyboard led on)… IS there any way to enable the keyboards leds and the other keys because I have done a search but I haven’t seen anything helpful ;D Thnks!

Please always at least tell your openSUSE version.

Opensuse 13.1 thanks ;D

I have a logitech G105 keyboard, but it has a button to swtich on/off the leds of the keys. However it works even during when the OS is booting up.

I know that there is a Asus Notebooks WMI hotkey kernel driver (aus-nb-wmi) that might take care of this functionality for you. Not sure which models it supports though.

Hi Deano_Feerrari the asus-nb-wmi has no support anymore or at least that’s what i read searching the web ;D I have seen that you can customize your keyboard behaviour with a temporary command like this example to enable the caps by pressing shift+Capslock

$; setxkbmap -option “caps:none”
$ setxkbmap -option “shift:both_capslock”

And also once you are sure that the command you tried worked well you can modify the /etc/X11/xorg.conf.d/10-keyboard.conf file

The example of the previous modification to make it permanent through .conf file modification was:Section “InputClass”
Identifier “system-keyboard”
MatchIsKeyboard “on”
Option “XkbLayout” “us”
Option “XkbModel” “pc104”
Option “XkbOptions” “shift:both_capslock,caps:none”
So!! Is there the possibility to enable the leds through this method? Do anybody know how to write the commands? Thnks ;D (I will keep on searching)

for the leds I tried the commands:

$sudo setleds-D +numroot’s password:
KDGKBLED: Función ioctl no apropiadapara el dispositivo Error reading current flags setting.Maybe you are not on the console?

“$xset led” 3 and or “$xset led on” don’twork… they give the message xset: unable to open display “”

I’m not aware of that. I have seen threads which mention that it did not load at boot, but it did do the trick when loaded. Obviously, this will depend on the model involved. (You might want to share the links where this is claimed.)

If you do

modinfo asus-nb-wmi

you’ll get the author contact details. Maybe worth contatcting…

I can’t help with the user-space commands you mention, and they’re unlikely to provide the solution you’re looking for anyway IMHO.