keyboard layout

Hello everyone,

I have just a simple question. How can I change the layout of my keyboad? I often need to switch between russian and german. I just couldn’t find keyboard languages in Yast or in Kde control center.

Thanks a lot,

If you’re using KDE4;

Geeko Head -> Configure Desktop -> Regional & Language -> Keyboard Layout, then Enable Keyboard layouts and choose the ones you need.

It would help to know which KDE you are using. I’ve a feeling that with control centre mentioned you are using 3 but maybe you are just using the old name?

On KDE4,

Open System Settings (KDE menu/applications/System Settings will find it)

Under “Personal Settings” goto Regional & Language.

Choose Keyboard Layout

Select Enable keyboard Layouts

Drag the ones from lie list on the left to Active Layouts in the right column.

Click Apply.

You should get a layout switcher thing in the task bar.

If you are still stuck and do need help with KDE3, I can reboot later to 11.0 where I have it installed and have a look.

Sorry Chrysantine. Your more concise reply wasn’t there when I started typing mine…

Thanks a lot guys. I just followed the steps of Jon_Freeman. No I can write russian too. Very fine.