Keyboard layout problems

I have openSUSE 11.2 with default GNOME desktop and i’m facing issues with keyboard layouts, which are changing randomly. Problem is that i have GNOME in Slovak language and therefore has openSUSE set durring installation my keyboard layout to ‘Slovak’ but i always change it to ‘Slovak QWERTY’ which suits me better.

Problem is that randomly system adds back to my layouts which are ‘Slovak QWERTY’ and ‘USA’ also original ‘Slovak’ layout which was previously removed.

I must always manually remove this third layout and it’s very frustrating. Many times on fresh system boot it’s anyway back and so on and on…

Where may lie the problem? Why is GNOME not respecting my settings? In Ubuntu i never have these basic issues. Are there on system boot some specific SUSE triggers which are overwriting my configuration?

From what I read you have some mixed settings. Take a look in Yast - System - Sysconfigeditor and search for LC. The values in the fields point out locale settings. You might find some discrepancies there.

I think it’s OK in there…

I’m not much into Gnome, don’t know where settings are in there. Sorry.

I’m having exactly the same problem with openSUSE 11.2 and Gnome.

Sometimes new keyboard layouts are added… a few days ago I realized that it happens sometimes when i accidentally press both “Shift” keys simultaneously. But right know I can’t reproduce it in that way…

Try looking at the settings in GDM, you can set the keyboard layout there when you log in. This has given me some headache, since this setting seems to override any settings made in GNOME.

If you use autologin (like I did), this is even more confusing. You have to log out of GNOME to get to the log in screen, where you can make the appropriate settings.

Which keyboard layout is the default one?